Bug 1465718 - Logging services are exist but "oadm diagnostics AggregatedLogging" reports the services are not found
Logging services are exist but "oadm diagnostics AggregatedLogging" reports t...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
Junqi Zhao
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 22:22 EDT by Junqi Zhao
Modified: 2017-08-16 15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-10 09:07:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logging diagnostics info (3.02 KB, text/plain)
2017-07-03 21:40 EDT, Junqi Zhao
no flags Details
logging diagnostics info (3.48 KB, text/plain)
2017-07-03 21:44 EDT, Junqi Zhao
no flags Details
issue reproduced (4.05 KB, text/plain)
2017-07-07 05:02 EDT, Junqi Zhao
no flags Details

  None (edit)
Description Junqi Zhao 2017-06-27 22:22:14 EDT
Description of problem:
Run "oadm diagnostics AggregatedLogging" command after deployed logging, it reports unable to find 'logging-es', 'logging-es-cluster',  'logging-kibana' services, but actually these services are exist
As for "Did not find ServiceAccounts: logging-deployer" error info, it is already reported in https://bugzilla.redhat.com/show_bug.cgi?id=1421623
# oadm diagnostics AggregatedLogging
[Note] Determining if client configuration exists for client/cluster diagnostics
Info:  Successfully read a client config file at '/root/.kube/config'
Info:  Using context for cluster-admin access: 'logging/host-8-175-206-host-centralci-eng-rdu2-redhat-com:8443/system:admin'

[Note] Running diagnostic: AggregatedLogging
       Description: Check aggregated logging integration for proper configuration
       
Info:  Found route 'logging-kibana' matching logging URL 'kibana.0627-z5z.qe.rhcloud.com' in project: 'logging'

ERROR: [AGL0515 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:97]
       Did not find ServiceAccounts: logging-deployer.  The logging infrastructure will not function 
       properly without them.  You may need to re-run the installer.
       
ERROR: [AGL0217 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:97]
       Expected to find 'logging-es' among the logging services for the project but did not.
       
ERROR: [AGL0217 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:97]
       Expected to find 'logging-es-cluster' among the logging services for the project but did not.
       
WARN:  [AGL0215 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:105]
       Expected to find 'logging-es-ops' among the logging services for the project but did not. This
       may not matter if you chose not to install a separate logging stack to support operations.
       
WARN:  [AGL0215 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:105]
       Expected to find 'logging-es-ops-cluster' among the logging services for the project but did not. This
       may not matter if you chose not to install a separate logging stack to support operations.
       
ERROR: [AGL0217 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:97]
       Expected to find 'logging-kibana' among the logging services for the project but did not.
       
WARN:  [AGL0215 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:105]
       Expected to find 'logging-kibana-ops' among the logging services for the project but did not. This
       may not matter if you chose not to install a separate logging stack to support operations.
       
[Note] Summary of diagnostics execution (version v3.6.122):
[Note] Warnings seen: 3
[Note] Errors seen: 4
# oc get svc
NAME                     CLUSTER-IP       EXTERNAL-IP   PORT(S)    AGE
logging-es               172.30.201.14    <none>        9200/TCP   16h
logging-es-cluster       172.30.210.198   <none>        9300/TCP   16h
logging-es-ops           172.30.176.229   <none>        9200/TCP   39m
logging-es-ops-cluster   172.30.220.66    <none>        9300/TCP   39m
logging-kibana           172.30.214.18    <none>        443/TCP    16h
logging-kibana-ops       172.30.46.91     <none>        443/TCP    38m

Version-Release number of selected component (if applicable):
Images from brew registry
logging-elasticsearch      v3.6                19ad6f8e4738        29 minutes ago      404.2 MB
logging-auth-proxy         v3.6                d94bddb3dcba        8 hours ago         214.8 MB
logging-kibana             v3.6                4eabc3acd717        21 hours ago        342.4 MB
logging-fluentd            v3.6                08e8a59602fe        21 hours ago        232.5 MB
logging-curator            v3.6                a0148dd96b8d        2 weeks ago         221.5 MB

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging via ansible
2. Run "oadm diagnostics AggregatedLogging" command
3.

Actual results:
"oadm diagnostics AggregatedLogging" reports unable to find 'logging-es', 'logging-es-cluster',  'logging-kibana' services, but actually these services are exist

Expected results:
Logging system running healthy & no issue found.

Additional info:
Comment 1 Junqi Zhao 2017-06-27 23:26:18 EDT
# oc version
oc v3.6.122
kubernetes v1.6.1+5115d708d7
features: Basic-Auth GSSAPI Kerberos SPNEGO
Comment 2 Rodolfo Carvalho 2017-06-29 06:14:54 EDT
Jeff, is there a difference in the logging components for 3.6 that would require changes to `oadm diagnostics`?
Comment 3 Rodolfo Carvalho 2017-06-29 06:16:07 EDT
Luke, could you please have a look at this too?
Comment 4 Luke Meyer 2017-06-29 09:08:27 EDT
Probably should not check for the logging-deployer service account anymore, but the other ERRORs seem like things that should be there.
Comment 5 Luke Meyer 2017-06-29 14:43:47 EDT
If I add `-d` I can see why it's not finding the services. The services are no longer created with the expected label.

============
debug: Checking for services in project 'logging' with selector 'logging-infra=support'

ERROR: [AGL0217 from diagnostic AggregatedLogging@openshift/origin/pkg/diagnostics/cluster/aggregated_logging/diagnostic.go:96]
       Expected to find 'logging-es' among the logging services for the project but did not.
===========

In fact the created services no longer have any labels whatsoever.
Comment 6 Luke Meyer 2017-06-29 16:01:14 EDT
The services not being found should be addressed by https://github.com/openshift/openshift-ansible/pull/4649

I suggest we leave https://bugzilla.redhat.com/show_bug.cgi?id=1421623 for the remaining items as those will be origin changes.
Comment 7 Rodolfo Carvalho 2017-06-30 04:36:47 EDT
Thanks, Luke. IIUC there is no released version where the labels are missing and this was a regression in 3.6, correct?
Comment 8 Luke Meyer 2017-06-30 07:20:01 EDT
Assuming the PR makes it into 3.6.0, yes.
Comment 9 Rodolfo Carvalho 2017-07-03 07:08:03 EDT
https://github.com/openshift/openshift-ansible/pull/4649 was merged, this is ready for testing.
Comment 10 Luke Meyer 2017-07-03 09:19:34 EDT
Not certain it's been built yet but probably by the time QE gets to this.
Comment 11 Junqi Zhao 2017-07-03 21:39:05 EDT
Tested, ops cluster was not enabled, but there were warn info showed it expected to find 'logging-es-ops', 'logging-es-ops-cluster', 'logging-kibana-ops' among the logging services for the project but did not.

See the attached file, if we decide to ignore these warn info, then I think we can close this defect.
Comment 12 Junqi Zhao 2017-07-03 21:40 EDT
Created attachment 1294019 [details]
logging diagnostics info
Comment 13 Junqi Zhao 2017-07-03 21:44 EDT
Created attachment 1294021 [details]
logging diagnostics info
Comment 14 Luke Meyer 2017-07-04 11:46:28 EDT
From your output it looks like this particular bug has been addressed. I'm using the other bug 1421623 and PR to downgrade the ops warnings to info and get rid of the error about the deployer service account.
Comment 15 Junqi Zhao 2017-07-07 05:02:15 EDT
It's reproduced, see the attached file
# openshift version
openshift v3.6.136
kubernetes v1.6.1+5115d708d7
etcd 3.2.1
Comment 16 Junqi Zhao 2017-07-07 05:02 EDT
Created attachment 1295231 [details]
issue reproduced
Comment 17 Luke Meyer 2017-07-07 07:07:05 EDT
(In reply to Junqi Zhao from comment #15)
> It's reproduced

What was the version of openshift-ansible used to produce this?

The issue was that the services were created without the right metadata that the diagnostic is looking for. The latest openshift-ansible 3.6 should be creating these correctly.
Comment 18 Luke Meyer 2017-07-07 09:53:41 EDT
Not a blocker so moving to 3.6.1. But I think it's likely fixed anyway unless the fix got reverted somehow.
Comment 19 Junqi Zhao 2017-07-10 00:22:49 EDT
(In reply to Luke Meyer from comment #17)
> (In reply to Junqi Zhao from comment #15)
> > It's reproduced
> 
> What was the version of openshift-ansible used to produce this?
> 
> The issue was that the services were created without the right metadata that
> the diagnostic is looking for. The latest openshift-ansible 3.6 should be
> creating these correctly.

Tested with the latest openshift-ansible version 3.6.139-1, this issue does not exist.

# rpm -qa | grep openshift-ansible
openshift-ansible-3.6.139-1.git.0.4ff49c6.el7.noarch
openshift-ansible-roles-3.6.139-1.git.0.4ff49c6.el7.noarch
openshift-ansible-docs-3.6.139-1.git.0.4ff49c6.el7.noarch
openshift-ansible-lookup-plugins-3.6.139-1.git.0.4ff49c6.el7.noarch
openshift-ansible-callback-plugins-3.6.139-1.git.0.4ff49c6.el7.noarch
openshift-ansible-playbooks-3.6.139-1.git.0.4ff49c6.el7.noarch
openshift-ansible-filter-plugins-3.6.139-1.git.0.4ff49c6.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.