Bug 1465732 - webconsole doesn't support destinationDir for build secret
webconsole doesn't support destinationDir for build secret
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.5.1
Unspecified Unspecified
medium Severity medium
: ---
: 3.7.0
Assigned To: Jessica Forrester
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 00:36 EDT by Kenjiro Nakayama
Modified: 2017-07-03 07:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-03 07:11:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3101501 None None None 2017-07-02 21:03 EDT

  None (edit)
Description Kenjiro Nakayama 2017-06-28 00:36:40 EDT
Description of problem:
- We would like webconsole to support '--build-secret "secret-npmrc:/etc"'.

https://docs.openshift.com/container-platform/3.5/dev_guide/builds/build_inputs.html#using-secrets-in-the-buildconfig
```
$ oc new-build \
    openshift/nodejs-010-centos7~https://github.com/openshift/nodejs-ex.git \
    --build-secret “secret-npmrc:/etc”
```

Version-Release number of selected component (if applicable):
- 3.5

How reproducible:
- 100%

Steps to Reproduce:
1. Add-to-project->node.js(whatever)->source secret

Actual results:
- It is possible to put source secret, but not possible to specify destinationDir.

Expected results:
- webconsole supports destinationDir.
Comment 1 Jessica Forrester 2017-06-30 13:40:33 EDT
A "source secret" is not the same as a "build secret" the UI has support for both types.  Source secrets are secrets used while cloning the source repository, they are used for authentication.  Build secrets are used by the build at build time, like with an npmrc file.  The console DOES support destination dir for build secrets, it is farther down in the build configuration Edit screen.

Note we do not support setting up build secrets during the Add to Project workflow because the form is already extremely complex.  Is it necessary that it be supported during add to project? Or is it sufficient that we support it by editing the build configuration afterward.
Comment 2 Kenjiro Nakayama 2017-07-02 20:40:40 EDT
I see. I'm sorry for my misunderstanding of build secret and source secret.

> Note we do not support setting up build secrets during the Add to Project workflow because the form is already extremely complex.  Is it necessary that it be supported during add to project? Or is it sufficient that we support it by editing the build configuration afterward.

For this, the reported customer was convinced by using CLI and edit yaml. Although I think that in the future we could get same request from another customer (especially after OpenShift Online release), I also don't like complex webconsole. So, let's close this ticket once.

Note You need to log in before you can comment on or make changes to this bug.