Bug 1465738 - perl-Env-C-0.14-2.fc27 FTBFS randomly: Failed test 'setenv does not leak'
perl-Env-C-0.14-2.fc27 FTBFS randomly: Failed test 'setenv does not leak'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Env-C (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 01:22 EDT by Petr Pisar
Modified: 2017-08-10 02:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Env-C-0.14-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 02:43:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github mschout/env-c/issues/3 None None None 2017-08-09 11:14 EDT

  None (edit)
Description Petr Pisar 2017-06-28 01:22:45 EDT
perl-Env-C-0.14-2.fc27 fails to build in F27 on i686 only because a test fails:

t/author-pod-syntax.t .... skipped: these tests are for testing by the author
#   Failed test 'setenv does not leak'
#   at t/leak.t line 31.
#          got: 2248
#     expected: 2250
# Looks like you failed 1 test of 1.
t/leak.t ................. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 

A difference between working and failing build root is:

perl-devel 	4:5.26.0-393.fc27 	> 	4:5.26.0-394.fc27
	perl 	4:5.26.0-393.fc27 	> 	4:5.26.0-394.fc27
	perl-libs 	4:5.26.0-393.fc27 	> 	4:5.26.0-394.fc27
	perl-Encode 	4:2.90-9.fc27 	> 	4:2.91-11.fc27
	glibc-devel 	2.25.90-7.fc27 	> 	2.25.90-15.fc27
	perl-IO 	1.38-393.fc27 	> 	1.38-394.fc27
	glibc 	2.25.90-7.fc27 	> 	2.25.90-15.fc27
	perl-macros 	4:5.26.0-393.fc27 	> 	4:5.26.0-394.fc27
	libcrypt-nss 	2.25.90-7.fc27 	> 	2.25.90-15.fc27
	perl-Errno 	1.28-393.fc27 	> 	1.28-394.fc27
	glibc-all-langpacks 	2.25.90-7.fc27 	> 	2.25.90-15.fc27
	glibc-common 	2.25.90-7.fc27 	> 	2.25.90-15.fc27
	glibc-headers 	2.25.90-7.fc27 	> 	2.25.90-15.fc27
	kernel-headers 	4.12.0-0.rc5.git2.1.... 	> 	4.12.0-0.rc6.git3.1....
	openssl-libs 	1:1.1.0f-3.fc27 	> 	1:1.1.0f-4.fc27
	rpm-plugin-selinux 	4.13.0.1-23.fc27 	> 	4.13.0.1-24.fc27
	rpm-libs 	4.13.0.1-23.fc27 	> 	4.13.0.1-24.fc27
	glib2 	2.53.2-1.fc27 	> 	2.53.3-1.fc27
	rpm-build-libs 	4.13.0.1-23.fc27 	> 	4.13.0.1-24.fc27
	rpm-build 	4.13.0.1-23.fc27 	> 	4.13.0.1-24.fc27
	rpm 	4.13.0.1-23.fc27 	> 	4.13.0.1-24.fc27

I cannot reproduce in a qemu virtual machine.
Comment 1 Petr Pisar 2017-08-09 11:14:15 EDT
This actually happens randomly on all plaforms (I saw x86_64 and ppc64)
Comment 2 Petr Pisar 2017-08-09 12:02:04 EDT
I will remove upstream's kludge and will respect Perl's default. If this won't work, I will remove the test.
Comment 3 Petr Pisar 2017-08-10 02:42:55 EDT
It did not help. It fails on ppc64. Disabling the test.

Note You need to log in before you can comment on or make changes to this bug.