Bug 146586 - Should BuildRequires: pkgconfig >= 0.14
Should BuildRequires: pkgconfig >= 0.14
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 19:44 EST by Yanko Kaneti
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-09 23:00:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2005-01-29 19:44:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050110 Galeon/1.3.19.99

Description of problem:
Should buildrequire pkg-config >= 0.14 because thats what the upstream
configure wants.

Version-Release number of selected component (if applicable):
glib2-2.6.1-1

How reproducible:
Always

Steps to Reproduce:
Try rebuilding the SRPM on a system with pkg-config < 0.14


Actual Results:  )


Additional info:
Comment 1 Yanko Kaneti 2005-03-09 22:44:38 EST
Care to elaborate why exactly WONTFIX ?
Comment 2 Matthias Clasen 2005-03-09 23:00:33 EST
Because cluttering the spec files with BuildRequires to protect
against ancient tools is not a particularly effective use of my time.
Fedora SRPM don't have to be buildable on every rpm-based system on
the world, and there has not been a single FC release with pkgconfig <
0.14.
Comment 3 Yanko Kaneti 2005-03-09 23:57:31 EST
The BuildRequire is already there, it just has the incorrect version.
Changing a number would hardly culutter anything.

anyway.....

Note You need to log in before you can comment on or make changes to this bug.