Bug 146620 - Kernel panic on shutdown - ieee1394 spinlock
Kernel panic on shutdown - ieee1394 spinlock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-30 15:49 EST by Michael A. Peters
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2005-01-30 15:49:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Only device that had been connected to FireWire was iPod, and it has
been unmounted AND ejected for hours (ejected as in /dev nodes been
removed, no "do not disconnect" message.

I needed to do something in windows, so I rebooted from gnome.
I think I physically disconnected iPod before choosing reboot, but it
is possible I chose reboot and then physically disconnected.

Here's the panic that resulted:

ieee 1394: sbp2: aborting sbp2 command
Test Unit Ready 00 00 00 00 00
Kernel panic - not syncing : drivers/ieee1394/sb2.c:505:
spin_is_locked on uninitialized spinlock c3237ac8

Hardware: A7N8X Deluxe w/ built in FireWire
Additional Belkin FireWire card in PCI slot

Fom lspci:

00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire
(IEEE 1394) Controller (rev a3)

01:09.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394
Controller (Link)

If it matters, the iPod connects to the onboard IEEE 1394 (the TI card
is only there for times when I need to connect a second 6-pin firewire
device, rare)

Version-Release number of selected component (if applicable):
2.6.10-1.741_FC3

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
This has only happened to me once - I've been connecting the iPod for
about a month (Christmas gift) 

Additional info:
Comment 1 Michael A. Peters 2005-03-16 23:29:44 EST
It has never happened to me again since - I don't know that it still an issue or
not.
Comment 2 Dave Jones 2005-07-15 16:45:21 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.