Bug 1466205 - [ovirt-engine-tools] info module on ovirt-engine-extensions-tool not working [NEEDINFO]
[ovirt-engine-tools] info module on ovirt-engine-extensions-tool not working
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Tools.Extensions (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.1
: ---
Assigned To: Ondra Machacek
Gonza
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 05:01 EDT by Gonza
Modified: 2017-12-08 11:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-08 11:03:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mperina: needinfo? (grafuls)
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)

  None (edit)
Description Gonza 2017-06-29 05:01:53 EDT
Description of problem:
ovirt-engine-extensions-tool info module does not print anything to stdout when invoked and it comes back with rc=1

Version-Release number of selected component (if applicable):
ovirt-engine-tools-4.2.0-0.0.master.20170627181935.git9424f9b.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. ovirt-engine-extensions-tool info --output=stdout configuration --extension-name=internal-authz

Actual results:
no output on stdout and rc=1

Expected results:
results printed on stdout and rc=0
Comment 1 Martin Perina 2017-07-10 12:19:36 EDT
It works for me fine with today's master build:

[mperina@mperina:~/ovirt-engine]$ ./bin/ovirt-engine-extensions-tool info --output=stdout configuration --extension-name=internal-authz
2017-07-10 18:17:05,699+02 INFO    ========================================================================
2017-07-10 18:17:05,728+02 INFO    ============================ Initialization ============================
2017-07-10 18:17:05,728+02 INFO    ========================================================================
2017-07-10 18:17:05,735+02 INFO    Loading extension 'internal-authz'
2017-07-10 18:17:05,738+02 INFO    Extension 'internal-authz' loaded
2017-07-10 18:17:05,739+02 INFO    Loading extension 'internal-authn'
2017-07-10 18:17:05,740+02 INFO    Extension 'internal-authn' loaded
2017-07-10 18:17:05,741+02 INFO    Initializing extension 'internal-authz'
2017-07-10 18:17:05,741+02 INFO    Extension 'internal-authz' initialized
2017-07-10 18:17:05,742+02 INFO    Initializing extension 'internal-authn'
2017-07-10 18:17:05,742+02 INFO    Extension 'internal-authn' initialized
2017-07-10 18:17:05,743+02 INFO    Start of enabled extensions list
2017-07-10 18:17:05,745+02 INFO    Instance name: 'internal-authn', Extension name: 'Internal Authn (Built-in)', Version: 'N/A', Notes: '', License: 'ASL 2.0', Home: 'http://www.ovirt.org', Author 'The oVirt Project', Build interface Version: '0',  File: '/home/mperina/ovirt-engine/etc/ovirt-engine/extensions.d/internal-authn.properties', Initialized: 'true'
2017-07-10 18:17:05,745+02 INFO    Instance name: 'internal-authz', Extension name: 'Internal Authz (Built-in)', Version: 'N/A', Notes: '', License: 'ASL 2.0', Home: 'http://www.ovirt.org', Author 'The oVirt Project', Build interface Version: '0',  File: '/home/mperina/ovirt-engine/etc/ovirt-engine/extensions.d/internal-authz.properties', Initialized: 'true'
2017-07-10 18:17:05,745+02 INFO    End of enabled extensions list
2017-07-10 18:17:05,745+02 INFO    ========================================================================
2017-07-10 18:17:05,746+02 INFO    ============================== Execution ===============================
2017-07-10 18:17:05,746+02 INFO    ========================================================================
ovirt.engine.extension.binding.jbossmodule.class: org.ovirt.engine.extensions.aaa.builtin.internal.InternalAuthz
ovirt.engine.extension.bindings.method: jbossmodule
config.authz.user.id: 51fa02d2-c81c-49d2-9aad-a3ff3af25532
ovirt.engine.extension.provides: org.ovirt.engine.api.extensions.aaa.Authz
config.authz.user.name: admin
ovirt.engine.extension.binding.jbossmodule.module: org.ovirt.engine.extensions.builtin
ovirt.engine.extension.name: internal-authz

[mperina@mperina:~/ovirt-engine]$ echo $?
0

If this is still not working for you, could you please attach debug logs?
Comment 2 Martin Perina 2017-10-23 09:58:50 EDT
Gonzalo, any updates?
Comment 3 Gonza 2017-11-02 09:25:32 EDT
Lost that build already but tried with [1] and issues is not recurring.

[1]
ovirt-engine-tools-4.2.0-0.0.master.20171010095230.git721740e.el7.centos.noarch
Comment 6 Ondra Machacek 2017-12-08 11:03:25 EST
This is most probably a test case issue, because it's not possible to reproduce.
We return rc=1, when there is parsing error of arguments, so to really see what's the issue you need to change the test case to also create logs or print errors.

Note You need to log in before you can comment on or make changes to this bug.