Bug 1466245 - Wrong sendmail requires
Wrong sendmail requires
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: BackupPC (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Shaw
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 06:38 EDT by Anton Guda
Modified: 2017-07-13 10:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: BackupPC-4.1.3-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 10:50:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2017-06-29 06:38:08 EDT
Description of problem:
The main mail servers is postfix or exim now.
PackupPC requires namely sendmail.


Version-Release number of selected component (if applicable):
BackupPC-4.1.3-1.fc27

How reproducible:
Always


Steps to Reproduce:
1. Have a system with postfix.
2. Try to update or install new BackupPC.

Actual results:
error: Failed dependencies:
        sendmail is needed by BackupPC-4.1.3-1.fc27.x86_64

Expected results:
No direct sendmail requires, may be 
'MTA' or 'server(smtp)' be sufficient.
Comment 1 Richard Shaw 2017-07-02 09:04:58 EDT
I like the server(smtp) idea, unfortunately the procmail package doesn't provide that capability.

# rpm -q --provides procmail
procmail = 3.22-39.fc24
procmail(x86-64) = 3.22-39.fc24
Comment 2 Richard Shaw 2017-07-02 09:18:18 EDT
Ok, I haven't researched this before so learning a bit... postfix provides a sendmail compatible interface though the alternatives method. Since BackupPC seems to really only understand how to send mail using the sendmail command I think it best to require postfix instead as it is the default smtp agent.
Comment 3 Kevin Fenzi 2017-07-03 17:36:16 EDT
Requires: server(smtp) should be what you want here... that should allow any of the MTAs that provide a sendmail like interface to satisfy the requires. :) 

procmail doesn't provide that, but thats right, it needs something like postfix, exim, sendmail to pipe the email to it, it doesn't handle things before that.
Comment 4 Richard Shaw 2017-07-03 17:56:31 EDT
What about just requiring /usr/sbin/sendmail? It's possible that another MTA could be packaged that doesn't provide a sendmail compatible binary. BackupPC is specifically looking for sendmail (or equivalent).
Comment 5 Kevin Fenzi 2017-07-03 18:04:02 EDT
Sure, that should work too... I guess 'server(smtp)' is the smtp server interface, so yeah, /usr/sbin/sendmail should work for the calling the binary.
Comment 6 Richard Shaw 2017-07-04 11:23:20 EDT
Well crap... I tried using mock to install "/usr/sbin/sendmail" and it installed postfix but when I tried installing my package with that requirement esmtp was installed instead. I can add a Recommend or Suggest for Fedora, but that won't work for EPEL...
Comment 7 Anton Guda 2017-07-04 12:42:58 EDT
esmtp may be sufficient for some cases.
In real servers, mail daemon will be installed before backup programs.
Comment 8 Kevin Fenzi 2017-07-04 12:59:51 EDT
Yes, thats expected. in the vast majority of cases the admin would have already installed {sendmail|postfix|exim|esmtp...} and then when they install BackupPC the dep would already be satisifed and nothing new would be installed. 

it allows the admin to choose which one they want, and if they didn't install any at all, they get whatever yum happens to think is 'best'. If they don't like it they can remove that and install the one they want. :)
Comment 9 Fedora Update System 2017-07-05 08:45:12 EDT
BackupPC-4.1.3-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3e89e74f15
Comment 10 Anton Guda 2017-07-05 10:53:03 EDT
BackupPC-4.1.3-2 seems to work for me.
Comment 11 Fedora Update System 2017-07-05 14:49:41 EDT
BackupPC-4.1.3-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3e89e74f15
Comment 12 Fedora Update System 2017-07-13 10:50:53 EDT
BackupPC-4.1.3-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.