Bug 1466351 - yum install rh-eclipse46 fails
yum install rh-eclipse46 fails
Status: ASSIGNED
Product: softwarecollections.org
Classification: Community
Component: Other (Show other bugs)
1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jan Staněk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 09:18 EDT by Jeffrey Miller
Modified: 2017-08-01 05:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Miller 2017-06-29 09:18:54 EDT
Description of problem:
Installing eclipse46 on Centos7 fails due to dependency resolution

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
# 1. Install a package with repository for your system:
# On CentOS, install package centos-release-scl available in CentOS repository:
$ sudo yum install centos-release-scl

# 2. Install the collection:
$ sudo yum install rh-eclipse461.


Actual results:
---> Package rh-eclipse46-runtime.x86_64 0:1-12.el7 will be installed
--> Finished Dependency Resolution
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-jgit
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-abrt
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-tm-terminal-connectors
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-versions-cvs
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-tasks-trac
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-equinox-osgi
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-webtools-javaee
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-webtools-servertools
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-builds-hudson
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-tasks-web
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ecf-runtime
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-jdt
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-dltk-ruby
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-systemtap
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-context-cdt
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ecf-core
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-rse
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-pydev
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-webtools-common
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-manpage
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-gef
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-perf
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-tasks-bugzilla
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-cdt
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ptp-gem
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-cdt-native
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-egit-mylyn
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-emf-runtime
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-p2-discovery
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-dltk-tcl
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-pde
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-valgrind
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-docs-epub
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-cdt-llvm
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-launchbar
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-cdt-qt
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-rpm-editor
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-platform
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-filesystem
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ptp-rm-contrib
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ptp-sdm
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-changelog
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-swt
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-docs-wikitext
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-linuxtools-vagrant
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-xsd
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-dltk
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-pydev-mylyn
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-epp-logging
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-builds
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-webtools-sourceediting
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-gcov
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-linuxtools-docker
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-context-pde
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-emf-core
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-egit
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-webtools-jsf
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-cdt-parsers
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-linuxtools
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-remote
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-linuxtools-javadocs
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-context-java
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-rse-server
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-versions-git
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-gprof
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-tm-terminal
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-dltk-sh
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ptp-sci
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mylyn-versions
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-linuxtools-libhover
Error: Package: rh-eclipse46-base-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-mpc
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-dltk-mylyn
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-oprofile
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-ptp
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-cdt-docker
Error: Package: rh-eclipse46-1-12.el7.x86_64 (centos-sclo-rh)
           Requires: rh-eclipse46-eclipse-dltk-rse
 You could try using --skip-broken to work around the problem


Expected results:
no errors

Additional info:
Comment 1 Alexander Kurtakov 2017-08-01 05:23:25 EDT
Is this bug still relevant ?

Note You need to log in before you can comment on or make changes to this bug.