Bug 1466422 - Chronyd not installed nor enabled or started after upgrade
Chronyd not installed nor enabled or started after upgrade
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
4.1.3.5
All All
unspecified Severity medium (vote)
: ovirt-4.1.5
: ---
Assigned To: Sandro Bonazzola
Lukas Svaty
: Unconfirmed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 10:28 EDT by Lukas Svaty
Modified: 2017-08-01 04:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 04:12:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
lsvaty: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2017-06-29 10:28:37 EDT
Description of problem:
After upgrading engine from previous version which does not have chornyd installed on hosts/engine it is not installed and started on new instance.
This behaviour is the same for hosts and engine.

Version-Release number of selected component (if applicable):
rhevm-4.1.3.5-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install 4.0 engine (with ntpd instead of chronyd)
2. Upgrade engine to 4.1
3. Check chronyd is running
4. Upgrade hosts to 4.1
5. Check chronyd is running on hosts

Actual results:
Chronyd is not installed nor running

Expected results:
Should be
Comment 1 Sandro Bonazzola 2017-06-29 11:58:47 EDT
(In reply to Lukas Svaty from comment #0)
> Description of problem:
> After upgrading engine from previous version which does not have chornyd
> installed on hosts/engine it is not installed and started on new instance.
> This behaviour is the same for hosts and engine.

Can you please detail what do you mean with "This behaviour is the same for hosts and engine."
Because as far as I can tell, ovirt-engine never required ntpd as rpm dependency and never tried to configure it, so I don't expect to see appearing any dependency on chrony or configuration migration from ntpd to chronyd at engine upgrade stage.

On the other hand, vdsm on 4.1 explicitly requires chrony as rpm dependency, so I expect to see it installed on hosts.
Comment 2 Lukas Svaty 2017-07-03 06:20:38 EDT
So IIUC.

We are not forcing ntp nor chorny on engine side- VERIFIED (no change after upgrade)

As for chrony we are installing the package, however not setting it up, running service or enabling the service.
Thus if before upgrade service was not running, we just install the package, right?

What is the purpose of this package installed if we are not setting it up? 

I believe we had this conversation as part of BZ#1466422, however we only agreed on installing chrony not setting it up. Wanna revisit?
Comment 3 Sandro Bonazzola 2017-08-01 04:11:44 EDT
(In reply to Lukas Svaty from comment #2)
> So IIUC.
> 
> We are not forcing ntp nor chorny on engine side- VERIFIED (no change after
> upgrade)

Correct, we didn't enforce ntpd and we are not enforcing chrony on engine side.

> As for chrony we are installing the package, however not setting it up,
> running service or enabling the service.
> Thus if before upgrade service was not running, we just install the package,
> right?

This is on host side since on engine we doesn't require chrony as a dependency.
Quoting mperina on this:
 by default after installation DHCP client inject its configuration into chronyd, so it should configured using DHCP. We definitely don't want to provide UI for manual NTP configuration, so here's status:

1. DHCP configured hosts - everything should work automatically (assuming DHCP server contains NTP configuration)
2. Statically configured hosts - admin needs to configure chrony manually


> 
> What is the purpose of this package installed if we are not setting it up? 

As above, DHCP injects NTP config into chrony

> 
> I believe we had this conversation as part of BZ#1466422, however we only
> agreed on installing chrony not setting it up. Wanna revisit?
Comment 4 Sandro Bonazzola 2017-08-01 04:12:26 EDT
As per comment #3 I'm closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.