Bug 1466425 - Can not disable Red Hat provided repository orphaned after manifest refresh
Can not disable Red Hat provided repository orphaned after manifest refresh
Status: CLOSED DUPLICATE of bug 1344391
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.2.10
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 10:35 EDT by Julio Entrena Perez
Modified: 2017-07-03 10:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 15:45:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julio Entrena Perez 2017-06-29 10:35:44 EDT
Description of problem:
Gluster 3.2 was erroneously released in Gluster 3.1 repository.
Release engineering fixed this by moving the 3.2 content to the Gluster 3 repository, see https://projects.engineering.redhat.com/browse/RCM-545 .

After refreshing the manifest in Satellite 6.2.10, the new Gluster 3 repository is available, but the previously synchronised Gluster 3.1 repository is no longer listed at Content -> Red Hat repositories, and therefore can not be disabled.

# hammer repository-set info --id 4406 --product-id 48
ID:                   4406
Name:                 Red Hat Gluster Storage 3 Server (RPMs)
Type:                 yum
URL:                  /content/dist/rhel/server/7/$releasever/$basearch/rhgs-server/3.1/os
GPG Key:              file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Label:                rh-gluster-3-for-rhel-7-server-rpms
Enabled Repositories: 
 1) ID:   583
    Name: Red Hat Gluster Storage 3.1 Server RPMs x86_64 7Server

# hammer repository-set disable --id 4406 --product-id 48 --releasever 7Server --basearch x86_64
Could not disable repository:
  Repository not found

Version-Release number of selected component (if applicable):
Satellite 6.2.10.

How reproducible:
Always

Steps to Reproduce:
1. Refresh manifest after repository changes
2. Try disabling the former repository 
3.

Actual results:
Repository can not be disabled

Expected results:
Repository can be disabled

Additional info:
Comment 5 jcallaha 2017-06-30 15:45:59 EDT

*** This bug has been marked as a duplicate of bug 1344391 ***

Note You need to log in before you can comment on or make changes to this bug.