Bug 1466469 - Documentation: remove the "Ceph Storage Nodes" section from "Pre-Upgrade Notes for the Overcloud"
Documentation: remove the "Ceph Storage Nodes" section from "Pre-Upgrade Note...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity unspecified
: async
: 10.0 (Newton)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 13:54 EDT by Alexander Chuzhoy
Modified: 2017-07-06 23:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 23:23:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2017-06-29 13:54:15 EDT
Documentation: remove the "Ceph Storage Nodes" section from "Pre-Upgrade Notes for the Overcloud"

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/upgrading_red_hat_openstack_platform/chap-upgrading_the_environment#sect-Pre-Upgrade_Notes_for_Overcloud

The "Ceph Storage Nodes" section isn't needed for OSP upgrades  OSP9->10 and newer.

It was needed for OSP8->OSP9
Comment 1 Dan Macpherson 2017-07-06 09:11:22 EDT
I've only just removed the key generation content. There's still a note there about including the resources for the Ceph Storage composable services since they're disabled by default.

Here's the updated documentation:

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/upgrading_red_hat_openstack_platform/#sect-Pre-Upgrade_Notes_for_Overcloud

How does it look, Sasha?
Comment 2 Alexander Chuzhoy 2017-07-06 11:39:16 EDT
So the thing is that by default the update template (/usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml)  already includes:
resource_registry:
  OS::TripleO::Services::CephMon: ../puppet/services/ceph-mon.yaml
  OS::TripleO::Services::CephOSD: ../puppet/services/ceph-osd.yaml
  OS::TripleO::Services::CephClient: ../puppet/services/ceph-client.yaml



And if a client uses a local/custom version of the file - it's up to him/her to use the new version + custom changes.

I'd say at least we need to change "Include" to something like "Make sure it's included"
Comment 4 Alexander Chuzhoy 2017-07-06 12:18:58 EDT
Perfect,
Thanks.
Comment 5 Dan Macpherson 2017-07-06 23:23:25 EDT
Neat. Thanks, Sasha!

Note You need to log in before you can comment on or make changes to this bug.