Bug 1466508 - [container-storage-setup] sfdisk unable to partition a disk
[container-storage-setup] sfdisk unable to partition a disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: container-storage-setup (Show other bugs)
7.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Vivek Goyal
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 16:33 EDT by CAI Qian
Modified: 2017-08-01 20:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 20:11:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2343 normal SHIPPED_LIVE new package: container-storage-setup 2017-08-08 18:51:31 EDT

  None (edit)
Description CAI Qian 2017-06-29 16:33:45 EDT
Description of problem:
# cat /etc/sysconfig/docker-storage-setup
DEVS=/dev/vdb

# container-storage-setup
Checking that no-one is using this disk right now ...
OK

Disk /dev/vdb: 20805 cylinders, 16 heads, 63 sectors/track
sfdisk:  /dev/vdb: unrecognized partition table type

Old situation:
sfdisk: No partitions found

sfdisk: trailing junk after number

sfdisk: bad input

This looks like a typo in create_partition_sfdisk() function,

    cat <<EOF | sfdisk $dev
unit: sectors
start=     2048, size=  ${size}, Id=8e
EOF

I managed to change one line as in the old docker-storage-setup and everything is working fine again.

${dev}1 : start=     2048, size=  ${size}, Id=8e

Version-Release number of selected component (if applicable):
container-storage-setup-0.3.0-2.git9b77bcb.el7.noarch

How reproducible:
always
Comment 1 Vivek Goyal 2017-06-30 10:35:13 EDT
Proposed a PR upstream.

https://github.com/projectatomic/container-storage-setup/pull/246

Cai Qian, can you give that a try and see if it works for you now.
Comment 5 errata-xmlrpc 2017-08-01 20:11:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2343

Note You need to log in before you can comment on or make changes to this bug.