This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 146651 - gnome panel crashes on multi-head configurations when accessing properties on the second monitor
gnome panel crashes on multi-head configurations when accessing properties on...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-themes (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 09:54 EST by Tirian Wilson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 23:40:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash screen of display :0 (with terminal) (394.12 KB, image/png)
2005-01-31 09:57 EST, Tirian Wilson
no flags Details
This shows the partially drawn properties window on screen :1 (110.46 KB, image/png)
2005-01-31 10:00 EST, Tirian Wilson
no flags Details

  None (edit)
Description Tirian Wilson 2005-01-31 09:54:04 EST
Description of problem:
This bug only seems to be present on the second monitor of a
multi-head setup.  I can change the properties of the first monitor
(screen :0) without problems, but if I try to change the properties of
the secondary screen (:1), both the properties app and the panels on
both monitors crash.  The properties window never gets fully drawn on
the second screen if the theme "Crux" is used (this may be true of
other themes, but I have not tried it yet).  If the default theme is
used, it will only crash when you click on the "background" tab.  



Version-Release number of selected component (if applicable):
gnome-panel-2.8.1-3


How reproducible:
Every time.

Steps to Reproduce:
1. create a new user account (to be sure that the config files are
clean. I first found it on an old account and thought it was a bad
config file because it took me some time to figure out how to
reproduce it on a clean configuration)
2. install a multi-head configuration and configure X
3. log into the new user
4. access "properties" on one of the panels on screen :0, and close
the window
5. access "properties" on screen :1
6. click on the "background" tab
7. the app, and all panels will now crash
8. the "properties" app will now crash on every invocation on screen :1
9.if the "Crux" theme is selected, steps 4-6 can be ignored, the app
will crash immediately (I do not know about other themes, but Crux
does cause this)

  
Actual results:
Crash off all panels.
Sometimes, they reload automatically, but sometimes gnome does not
seem to catch that they have crashed and does not reload them.


Expected results:
The properties app should have remained open and the settings should
be allowed to change.


Additional info:
#####################################################################
Here is the terminal output from a crash:
###############
[tirian@milo ~]$ gnome-panel
looking for type: got text/plain
The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 4859 error_code 8 request_code 56 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)

######################################################################
Here it is again with --sync enabled:
################
[tirian@milo ~]$ gnome-panel --sync
looking for type: got text/plain
The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 8704 error_code 8 request_code 56 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 8705 error_code 8 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
Comment 1 Tirian Wilson 2005-01-31 09:57:33 EST
Created attachment 110434 [details]
crash screen of display :0 (with terminal)

This shows the two windows opening on display :0 when the properties app
crashes on screen :1
Comment 2 Tirian Wilson 2005-01-31 10:00:20 EST
Created attachment 110435 [details]
This shows the partially drawn properties window on screen :1

This only occurs with the "Crux" theme (as far as I can tell), if the standard
theme is used, it will draw the window correctly, but then crash when you click
on the "background" tab.
Comment 3 Mark McLoughlin 2005-01-31 13:10:19 EST
Yeah, its a Crux bug - it may have been fixed upstream already, I
recall seeing a bug go by I think

Note You need to log in before you can comment on or make changes to this bug.