Bug 1466532 - typo in stock config file for cinder
typo in stock config file for cinder
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: zstream
: 8.0 (Liberty)
Assigned To: Eric Harney
Avi Avraham
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 19:05 EDT by Siggy Sigwald
Modified: 2017-11-06 09:24 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-cinder-7.0.3-9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-06 09:24:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siggy Sigwald 2017-06-29 19:05:12 EDT
Description of problem:
As mentioned in upstream doc[1] the correct value should be max_over_subscription_ratio - notice the extra _ UNDERSCORE
Taken from stock cinder.conf:
nfs_oversub_ratio = 1.0

(FloatOpt) This will compare the allocated to available space on the volume destination. If the ratio exceeds this number, the destination will no longer be valid. Note that this option is deprecated in favor of "max_oversubscription_ratio" and will be removed in the Mitaka release.

[1]https://docs.openstack.org/liberty/config-reference/content/nfs-driver-options.html
Version-Release number of selected component (if applicable):


How reproducible:
typo seems present in at least rhosp 7/8/9
Comment 3 Tzach Shefi 2017-10-01 08:56:23 EDT
Eric,

Just to be sure before I verify,
is this just the below typo which needed verification
as the bz title suggests, or do I need to check something else? 

vi /usr/lib/python2.7/site-packages/cinder/volume/drivers/nfs.py
    cfg.FloatOpt('nfs_oversub_ratio',
                 default=NFS_OVERSUB_RATIO_DEFAULT,
                 help=('This will compare the allocated to available space on '
                       'the volume destination.  If the ratio exceeds this '
                       'number, the destination will no longer be valid. '
                       'Note that this option is deprecated in favor of '
                       '"max_over_subscription_ratio" and will be removed '

Was ->  max_oversubscription_ratio" before the fix. 

Cinder.conf, also now "max_over_subscription_ratio"-> 
# This will compare the allocated to available space on the volume destination.
# If the ratio exceeds this number, the destination will no longer be valid.
# Note that this option is deprecated in favor of "max_over_subscription_ratio"
# and will be removed in the Mitaka release. (floating point value)
#nfs_oversub_ratio = 1.0
Comment 4 Eric Harney 2017-10-02 09:11:59 EDT
(In reply to Tzach Shefi from comment #3)
> Eric,
> 
> Just to be sure before I verify,
> is this just the below typo which needed verification
> as the bz title suggests, or do I need to check something else? 
> 

Correct, this is just fixing the typo in the description of the option, no runtime changes.
Comment 6 Tzach Shefi 2017-10-02 20:02:39 EDT
Verified on:
openstack-cinder-7.0.3-9.el7ost.noarch

according to comments #3-4
Comment 9 errata-xmlrpc 2017-11-06 09:24:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3121

Note You need to log in before you can comment on or make changes to this bug.