Bug 146665 - Compiling PHP with Sablotron Error
Summary: Compiling PHP with Sablotron Error
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-31 16:46 UTC by mlbossi
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 16:49:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mlbossi 2005-01-31 16:46:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
We tried to rebuild the PHP 3.4.10 with Sablotron 1.0.2 from the
sources adding the following options in the php.spec file:

    --enable-xslt \
    --with-xlst-sablot \
    --with-sablot-js \

but we get always this error:


... (skip) ...

SKIP PEAR_Installer test #2 [pear/tests/pear_installer2.phpt]
SKIP PEAR_Installer test #3 File Transactions
[pear/tests/pear_installer3.phpt]
SKIP PEAR_Installer test #4: PEAR_Installer::install()
[pear/tests/pear_installer4.phpt]
SKIP PEAR_Installer test #5: test directory tracking/deletion of
installation [pear/tests/pear_installer5.phpt]
SKIP PEAR_Packager test [pear/tests/pear_packager.phpt]
SKIP PEAR_Registry [pear/tests/pear_registry.phpt]
SKIP System commands tests [pear/tests/pear_system.phpt]

=====================================================================
TIME END 2005-01-31 12:28:59
=====================================================================
TEST RESULT SUMMARY
---------------------------------------------------------------------
Exts skipped    :   56
Exts tested     :   31
---------------------------------------------------------------------
Number of tests :  608
Tests skipped   :  204 (33.6%)
Tests warned    :    0 (0.0%)
Tests failed    :    1 (0.2%)
Tests passed    :  403 (66.3%)
---------------------------------------------------------------------
Time taken      :   43 seconds
=====================================================================

=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
xslt_set_object function [ext/xslt/tests/xslt_set_object.phpt]
=====================================================================
make: *** [test] Error 1
+ set +x
TEST FAILURE: ../ext/xslt/tests/xslt_set_object.diff --
001- OK
001+ Warning: Sablotron error on line 1: XML parser error 3: no
element found in
/usr/src/redhat/BUILD/php-4.3.10/ext/xslt/tests/xslt_set_object.php on
line 19
002- OK
002+
003+ Warning: Sablotron error on line 1: XML parser error 3: no
element found in
/usr/src/redhat/BUILD/php-4.3.10/ext/xslt/tests/xslt_set_object.php on
line 30
004+ OK
005+ OK-- ../ext/xslt/tests/xslt_set_object.diff result ends.
error: Bad exit status from /var/tmp/rpm-tmp.48369 (%check)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.48369 (%check)

We have also installed sablotron-devel, js 1.5, js-devel, expat
1.95.7a and expat-devel.


Version-Release number of selected component (if applicable):
php-4.3.10-3.2  sablotron-1.0.2-0.n0i.1

How reproducible:
Always

Steps to Reproduce:
1. Install the packages
2. Modifify the /usr/src/redhat/SPECS/php.spec file
3. run rpmbuild -bb /usr/src/redhat/SPECS/php.spec
    

Actual Results:  See above Description.

Additional info:

The sablotron and sablotron-devel binary rpms come from http://reb00t.com

Comment 1 Joe Orton 2005-01-31 16:49:52 UTC
Please report the test failures upstream to bugs.php.net since we do
not ship sablotron in Fedora Core.


Note You need to log in before you can comment on or make changes to this bug.