Bug 1466795 - dnf distro-sync failed on python2 issues
dnf distro-sync failed on python2 issues
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 09:22 EDT by Matus Kocka
Modified: 2017-06-30 09:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 09:31:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matus Kocka 2017-06-30 09:22:30 EDT
sudo dnf --releasever=25 --allowerasing downgrade fedora-release
sudo dnf distro-sync --allowerasing

after packages are downloaded: 

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /lib64/libreadline.so.6.3 from install of readline-6.3-8.fc24.x86_64 conflicts with file from package compat-readline6-6.3-11.fc26.x86_64
  file /usr/lib64/libhistory.so.6.3 from install of readline-6.3-8.fc24.x86_64 conflicts with file from package compat-readline6-6.3-11.fc26.x86_64
  file /usr/lib/python2.7/site-packages/iniparse-0.4-py2.7.egg-info from install of python2-iniparse-0.4-20.fc25.noarch conflicts with file from package python2-iniparse-0.4-24.fc26.noarch

Error Summary
Comment 1 Igor Gnatenko 2017-06-30 09:31:13 EDT
are you trying to downgrade?

downgrade paths are not supported.

Note You need to log in before you can comment on or make changes to this bug.