This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1466857 - [DOCS] We need to add a downstream doc about accessing metrics using hawkular-metrics
[DOCS] We need to add a downstream doc about accessing metrics using hawkular...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brandi
Junqi Zhao
Vikram Goyal
3.7-release-plan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 11:00 EDT by Eric Jones
Modified: 2017-10-12 17:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-03 10:00:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2017-06-30 11:00:47 EDT
Document URL: 
https://github.com/openshift/origin-metrics/blob/master/docs/hawkular_metrics.adoc#accessing-metrics-using-hawkular-metrics

Describe the issue: 
We have upstream docs about hitting the metrics url directly to query information but nothing in the official documentation
Comment 1 Brandi 2017-08-24 14:39:56 EDT
Hi Eric, 

We have the following sections in the Documentation:

Deploying the Hawkular OpenShift Agent
https://docs.openshift.com/container-platform/3.5/install_config/cluster_metrics.html#deploying-hawkular-openshift-agent

Accessing Hawkular Metrics Directly
https://docs.openshift.com/container-platform/3.5/install_config/cluster_metrics.html#cluster-metrics-accessing-hawkular-metrics-directly

Do you think it would be helpful to link directly to the "Accessing Metrics Using Hawkular Metrics" GitHub documentation in the "Accessing Hawkular Metrics Directly" section of our documentation?
Comment 5 Junqi Zhao 2017-09-22 04:58:56 EDT
Brandi,

Same concern with Eric, but I am fine with your solution, if there is something wrong in the upstream documentation, we should change the upstream documentation.

Wait for your reply of Comment 4, then I can close this defect
Comment 6 Brandi 2017-09-22 10:26:31 EDT
Eric an Junqi,

Thank you both for your feedback! 

I can draft the content specifically related to 3.5, but would you be able to help me figure out if the content that is currently in there is correct for 3.5? Also, would you like it to be in place just for 3.5 or 3.5 forward?

Thanks again!
Comment 7 Junqi Zhao 2017-09-24 21:01:33 EDT
@Brandi,

I think your current solution in PR 5273 is OK, since https://github.com/openshift/origin-metrics/blob/master/docs/hawkular_metrics.adoc#accessing-metrics-using-hawkular-metrics is applicable for Metircs 3.5, 3.6, 3.7 now, if we draft the content for Metrics 3.5, then we have to do the same for Metircs 3.6, 3.7, it is redundant.

@Eric
What do you think?
Comment 8 Junqi Zhao 2017-09-27 20:20:09 EDT
Eric,

Please see my Comment 7
Comment 9 Brandi 2017-09-28 09:35:17 EDT
@Junqi, 

Ah yes, that does make sense. 

Thanks!
Comment 10 Junqi Zhao 2017-09-28 20:32:25 EDT
Documentation is LGTM.

Set it to verified.
Comment 11 openshift-github-bot 2017-09-29 11:57:12 EDT
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/13c22fa44b3ea03242c12e8d7161084a31990e87
Bug 1466857 Add link to Accessing Metrics Using Hawkular Metrics Upstream Documentation

https://github.com/openshift/openshift-docs/commit/9453ef88b5867371ac43619e1a59f79619b70d89
Merge pull request #5273 from bmcelvee/BZ1466857

Bug 1466857 Add link to Accessing Metrics Using Hawkular Metrics Upstream Documentation

Note You need to log in before you can comment on or make changes to this bug.