Bug 1466928 - Review Request: pagure-dist-git - Pagure gitolite plugin for Fedora's dist-git setup.
Review Request: pagure-dist-git - Pagure gitolite plugin for Fedora's dist-gi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zbigniew Jędrzejewski-Szmek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 14:38 EDT by Ralph Bean
Modified: 2017-08-12 10:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-12 10:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
zbyszek: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Ralph Bean 2017-06-30 14:38:08 EDT
Spec URL: http://ralph.fedorapeople.org//pagure-dist-git.spec
SRPM URL: http://ralph.fedorapeople.org//pagure-dist-git-0.1-1.fc25.src.rpm

Description:
Since 3.0 pagure offers a way to customize the creation and compilation the
of the gitolite configuration file.

This project hosts the logic to generate gitolite's configuration file for
dist-git which has a different access model than regular projects on pagure
(for example, forced pushed is forbidden).
Comment 1 Ralph Bean 2017-06-30 14:38:12 EDT
This package built on koji:  https://koji.fedoraproject.org/koji/taskinfo?taskID=20268167
Comment 2 Zbigniew Jędrzejewski-Szmek 2017-07-04 11:55:47 EDT
I'd prefer to have the python3 subpackage too, unless it's really broken, but that's you choice.

python2-pagure-dist-git.noarch: W: summary-ended-with-dot C Pagure gitolite plugin for Fedora's dist-git setup.

+ package name is OK
+ license is acceptable for Fedora (GPLv2+)
+ license is specified correctly
+ builds and installs OK
+ provides/requires/build-requires look correct
+ fedora-review finds no issues
+ modern python packaing template is used

Change http to https in Url.

Package is APPROVED.
Comment 3 Ralph Bean 2017-08-11 16:51:16 EDT
Thanks zbyszek!
Comment 4 Gwyn Ciesla 2017-08-11 17:25:01 EDT
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/pagure-dist-git
Comment 5 Gwyn Ciesla 2017-08-11 17:25:10 EDT
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/pagure-dist-git

Note You need to log in before you can comment on or make changes to this bug.