Bug 1467082 - [Perf] : ls and stats have regressed by ~60%
[Perf] : ls and stats have regressed by ~60%
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha (Show other bugs)
3.3
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kaleb KEITHLEY
Ambarish
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-02 11:09 EDT by Ambarish
Modified: 2017-08-10 03:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-04 22:59:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ambarish 2017-07-02 11:09:39 EDT
Description of problem:
-----------------------

Baseline : RHGS 3.2 + NFS Ganesha 2.4.1-9

Currently testing Ganesha 2.4.4-10 and Gluster 3.8.4-32 build.

*ls-l* :

3.2 : 1210 files/sec

Latest 3.3 bits : 465 files/sec

Regression : ~60%

*stat* :

3.2 : 1218 files/sec

Latest 3.3 bits : 495 files/sec

Regression : ~60%

Volume Profiles will be updated.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

nfs-ganesha-debuginfo-2.4.4-10.el7rhgs.x86_64
glusterfs-ganesha-3.8.4-32.el7rhgs.x86_64


How reproducible:
-----------------

Every which way I try.


Additional info:
-----------------

Volume Name: testvol
Type: Distributed-Replicate
Volume ID: a50c906d-1c2f-4942-b31b-4ad2a2223b3d
Status: Started
Snapshot Count: 0
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: gqas001.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick0
Brick2: gqas004.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick1
Brick3: gqas010.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick2
Brick4: gqas012.sbu.lab.eng.bos.redhat.com:/bricks/testvol_brick3
Options Reconfigured:
client.event-threads: 4
server.event-threads: 4
cluster.lookup-optimize: on
ganesha.enable: on
features.cache-invalidation: on
server.allow-insecure: on
performance.stat-prefetch: off
transport.address-family: inet
nfs.disable: on
nfs-ganesha: enable
cluster.enable-shared-storage: enable
Comment 5 Ambarish 2017-07-04 22:59:55 EDT
False Alarm!

This seems to occur since the volume got mounted by v4.1(https://bugzilla.redhat.com/show_bug.cgi?id=1375259) and I missed that while opening this BZ.

Mounting via v4.0,the perf regression for this test is within limits that my tests are allowed to have between releases/dev builds.

Closing as Nab,and apologies for the unnecessary noise.
Comment 6 Ambarish 2017-08-10 03:19:37 EDT
Upstream BZ to track this : https://bugzilla.redhat.com/show_bug.cgi?id=1480098

Note You need to log in before you can comment on or make changes to this bug.