Bug 1467197 - [New UI] - UI exception when choosing VM and then switching from VMs to Hosts tab and vise versa
[New UI] - UI exception when choosing VM and then switching from VMs to Hosts...
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
unspecified Severity low (vote)
: ovirt-4.2.0
: ---
Assigned To: Greg Sheremeta
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 03:11 EDT by Michael Burman
Modified: 2017-08-20 02:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-20 02:40:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
record1 (4.43 MB, application/x-gzip)
2017-07-03 03:11 EDT, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2017-07-03 03:11:37 EDT
Created attachment 1293768 [details]
record1

Description of problem:
[New UI] - UI exception when choosing VM and then switching from VMs to Hosts tab and vise versa .

UI exception is occurred when choosing specific VM and then switching between VMs and Hosts tabs.

2017-07-03 09:54:29,120+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-4) [] Permutation name: D424918EE08B7776CAEC040E554E3FF9
2017-07-03 09:54:29,121+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-4) [] Uncaught exception: com.google.web.bindery.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 't' of null
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_131]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_131]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$fireEventFromSource(SimpleEventBus.java:92) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.SimpleEventBus.$fireEventFromSource(SimpleEventBus.java:61) [gwt-servlet.jar:]

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170702100738.git46a9f67.el7.centos

How reproducible:
100%

Steps to Reproduce:
1. Go to VMs tab > choose VM > go to Hosts tab > choose host > go to VMs under host > choose VM > go to VMs tab

Actual results:
Uncaught exception: com.google.web.bindery.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 't' of null

Expected results:
No exceptions
Comment 1 Michael Burman 2017-07-05 09:22:53 EDT
This UI exception is caught for other flows in the ui as well. Looks like moving from entities in tabs and then going back giving this as well. I see this exception a lot when from tabs or from entities in tabs.

Another example:
- Go to VMs
- Choose VM
- Choose vNIC
- Go back to VMs main list
100% reproducible
Comment 2 Greg Sheremeta 2017-08-17 12:44:10 EDT
I can't reproduce on master. Still happen for you?
Comment 3 Michael Burman 2017-08-20 01:04:20 EDT
(In reply to Greg Sheremeta from comment #2)
> I can't reproduce on master. Still happen for you?

Not on 4.2.0-0.0.master.20170818152502.gita8c361f.el7.centos

Note You need to log in before you can comment on or make changes to this bug.