Bug 146748 - Packages requiring root access to run can be installed without usermode-gtk.
Packages requiring root access to run can be installed without usermode-gtk.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 04:22 EST by Justin Szeto
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 18:42:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Szeto 2005-02-01 04:22:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
During a custom installation, I can select any of the system-config-*
packages, all requiring root access to run, and deselect the
usermode-gtk package. After installation, attempting to run any of
these system-config-* packages without usermode-gtk causes them to
fade away into the night :)

Version-Release number of selected component (if applicable):
comps-3-0.20041103

How reproducible:
Always

Steps to Reproduce:
1. During a custom installation of FC3, deselect usermode-gtk
2. After installation, attempt to run any of the system-config-* packages.
    

Actual Results:  The packages do not start up due to missing package
usermode-gtk

Expected Results:  usermode-gtk should be installed if any of the
system-config-* packages are installed.

Additional info:

I think all the system-config-* packages should be moved out of X
Windows System and moved to the Administration Tools. usermode-gtk
should then be made a mandatory (standard) package of Administration
Tools.
The following packages appear in both package groups anyway:
system-config-soundcard
system-logviewer
system-config-date
system-config-packages
system-config-users
system-config-network
The following packages appear in X Window System but not in
Administration Tools, but I see no reason why not?
system-config-printer-gui
system-config-services
system-switch-mail-gnome
system-config-display
Another solution is to make usermode-gtk mandatory for X Window
System, but I like this solution far less.
My apologies to the comps maintainer for picking on him! :)
Comment 1 Elliot Lee 2005-05-11 18:42:12 EDT
User error - if installing things that way breaks, don't do that.

Note You need to log in before you can comment on or make changes to this bug.