Bug 1467570 - Update Netty to 4.0.44+
Update Netty to 4.0.44+
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netty (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Simacek
Fedora Extras Quality Assurance
:
Depends On: 1469486
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 04:45 EDT by Tomas Repik
Modified: 2017-08-16 10:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: netty-0:4.1.13-1.fc27.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 10:11:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (392.29 KB, patch)
2017-07-11 09:13 EDT, Michael Simacek
no flags Details | Diff

  None (edit)
Description Tomas Repik 2017-07-04 04:45:47 EDT
The latest release of Cassandra (3.11) requires newer version of Netty (4.0.44) I'd like to update Cassandra in rawhide and having new Netty as well would be nice. I can help with the update if needed.
It's not only Cassandra but also mongo-java-driver that requires newer version of Netty. 

Thanks
Comment 1 Christopher Tubbs 2017-07-06 15:20:36 EDT
Latest 4.0 appears to be 4.0.49, but current patches don't apply cleanly. Needs some tweaking. Didn't try newer versions (4.1 or 5.0).
Comment 2 Michael Simacek 2017-07-07 09:27:32 EDT
Latest release is 4.1.13, is there a reason why not update to that directly?

mongo-java-driver specifies 4.1.5 in the latest pom on maven central
Comment 3 Christopher Tubbs 2017-07-10 17:06:00 EDT
(In reply to Michael Simacek from comment #2)
> Latest release is 4.1.13, is there a reason why not update to that directly?
> 
> mongo-java-driver specifies 4.1.5 in the latest pom on maven central

No reason I can think of. I know Netty tries to be careful about backwards compatibility, and the major version hasn't changed, so it shouldn't break anything to move to the latest.
Comment 4 Michael Simacek 2017-07-11 09:13 EDT
Created attachment 1296252 [details]
Proposed patch
Comment 5 Michael Simacek 2017-07-11 09:15:33 EDT
Patch for review, needs jctools to be updated, not tested. I'm leaving for a vacation now, so feel free to apply the patch if jctools gets updated
Comment 6 Jan Kurik 2017-08-15 05:22:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Note You need to log in before you can comment on or make changes to this bug.