Bug 1467579 - Switch to OpenGL2 backend
Switch to OpenGL2 backend
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 05:15 EDT by Armin Wehrfritz
Modified: 2017-07-04 05:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-04 05:39:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armin Wehrfritz 2017-07-04 05:15:52 EDT
For the current packages ParaView is still built with the legacy rendering backend (probably because the cmake configuration still defaults to this).

However, this backend receives little testing anymore from the upstream developers and the new OpenGL2 backend (requiring OpenGL 3.2+ drivers) is the default for the official ParaView builds since January 2016 [1]. 

Also, the OpenGL2 backend is significantly faster than the legacy rendering backend.

The new backend can be easily selected by setting:
    -DVTK_RENDERING_BACKEND:STRING="OpenGL2"

Thanks for considering this request.

[1] https://www.paraview.org/pipermail/paraview/2017-May/040215.html

Note You need to log in before you can comment on or make changes to this bug.