Bug 146762 - Kernel 2.6.9 fails to detect SATA hard disk on ICH5
Kernel 2.6.9 fails to detect SATA hard disk on ICH5
Status: CLOSED DUPLICATE of bug 138405
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-02-01 08:42 EST by Rainer Koenig
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:08:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Sysreport for 2GB RAM (this config is working) (298.30 KB, application/octet-stream)
2005-02-08 07:44 EST, Rainer Koenig
no flags Details
Sysreport for 4GB RAM (this config is NOT working) (296.33 KB, application/octet-stream)
2005-02-08 07:45 EST, Rainer Koenig
no flags Details

  None (edit)
Description Rainer Koenig 2005-02-01 08:42:17 EST
Description of problem:
Trying to install on a Dual Xeon workstation with SATA hard disk
connected to the onboard ICH5 controller fails because the install
kernel doesn't detect the hard disk.

Version-Release number of selected component (if applicable):

How reproducible:
Always, and also other distributions are suffering from that (e.g. FC3).

Steps to Reproduce:
1. Boot from CD1
2. System shows that there are no hard disks detected, even with a
SATA disk connected to the boad.

Actual results:
Unable to install RHEL 4 beta 2 on that system.

Expected results:
SATA disks work fine.

Additional info:
Problem seems to be limited to x86_64 architecture, trying out e.g. a
Fedora Core 3 for i386 doesn't show it while FC3 for x86_64 shows it.

Problem seems to be fixed in 2.6.10. At least an installation on a
normal IDE disk was able to detect the SATA drive after installing
kernel 2.6.10 from kernel.org.
Comment 1 John W. Linville 2005-02-07 15:14:31 EST
Please attach the output of running "sysreport" as an initial step in
the investigation...thanks!
Comment 2 Rainer Koenig 2005-02-08 07:44:53 EST
Created attachment 110791 [details]
Sysreport for 2GB RAM (this config is working)
Comment 3 Rainer Koenig 2005-02-08 07:45:47 EST
Created attachment 110792 [details]
Sysreport for 4GB RAM (this config is NOT working)
Comment 4 Rainer Koenig 2005-02-08 07:50:22 EST
Ok, I installed RH4 Public Beta 2 on a normal IDE disk to get the
sysreport information. And I found out one amazing thing:

If the system is equipped with 2 GB RAM then it works, the SATA disk
is recognized and working. 

If the system is equipped with 4 GB RAM then it does NOT work, the
SATA disk is not recognized. 

So I uploaded 2 sysreports, one for the configuration with 4 GB and
one for the configuration with 2 GB. 

My next step will be downgrading the BIOS to earlier versins that
don't do remapping of the memory between 3 and 4 GB. That's one major
difference I think, if I use 2 GB there is no remapping happening, if
I use 4 GB BIOS is remapping some parts of the memory. 
Comment 5 Rainer Koenig 2005-02-08 08:45:21 EST
Latest development in this problem: I switched back to an earlier BIOS
release and the problem disappeared with 4 GB, even with memory
remapping enabled. As a result of this I do 2 things I lower the
Severity to "normal" and on the other hand I'll try out what changes
were applied to the BIOS.
Comment 6 Rainer Koenig 2005-02-08 08:46:22 EST
oops... last sentence should be "try to find out what changes were
applied to the BIOS". :-)
Comment 8 Jeff Garzik 2005-02-18 00:57:41 EST

*** This bug has been marked as a duplicate of 138405 ***
Comment 9 Rainer Koenig 2005-02-18 01:34:27 EST
If I try to see bug 138405 I get the following message:

 You are not authorized to access bug #138405. 

Nice :-(
Comment 10 John W. Linville 2005-02-18 09:00:45 EST

I don't know if I can give you access to bug 138405 or not.  I can
tell you that it was resolved as "CURRENTRELEASE", implying that the
newly released RHEL4 should resolve the problem you are seeing.

Please attempt to recreate the problem w/ the current RHEL4 release,
and reopen this bug if the problem still occurs.
Comment 11 Red Hat Bugzilla 2006-02-21 14:08:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.