Bug 1467639 - vms/instances view gets broken when user switches to that view from timelines page
vms/instances view gets broken when user switches to that view from timelines...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.8.2
Assigned To: Harpreet Kataria
Ievgen Zapolskyi
ui:vm:timeline
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 08:27 EDT by Ievgen Zapolskyi
Modified: 2017-09-26 09:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-26 09:15:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core
izapolsk: automate_bug-


Attachments (Terms of Use)
exception (7.91 KB, text/plain)
2017-07-04 08:27 EDT, Ievgen Zapolskyi
no flags Details
screenshot (121.43 KB, image/png)
2017-07-04 08:27 EDT, Ievgen Zapolskyi
no flags Details

  None (edit)
Description Ievgen Zapolskyi 2017-07-04 08:27:03 EDT
Created attachment 1294179 [details]
exception

Description of problem:
It seems the issue is in either accordion or transitions to Instances/Virtual Machines page. I don't have exact steps but when I go through some combination of steps several times I get this error.
Exception and screenshot are attached.
btw, I saw this error many times with different combinations of steps.

Version-Release number of selected component (if applicable):
5.8.1.0

How reproducible:
100% but user may need to should run through steps several times 

Steps to Reproduce:
1. Add f.e. azure provider
2. Go to Compute->Clouds->Instances
3. Choose Instances accordion there
4. Click any instance 
5. Click Relationships->Availability Zone on instance details page
6. Open Timelines for that Availability Zone and Click Apply
7. Go to Compute->Clouds->Instances and click All Instances in Instances accordion
8. Go to Compute->Clouds->Availability Zones
9. choose any zone and open Timelines for it
10. Go to Compute->Clouds->Instances again 

Actual results:
somewhere among these steps Instances page gets broken and shows only the following error
"undefined method `deep_clone' for nil:NilClass Did you mean? deep_send [vm_cloud/explorer]"

Expected results:
no such error
Comment 2 Ievgen Zapolskyi 2017-07-04 08:27 EDT
Created attachment 1294181 [details]
screenshot
Comment 3 Dave Johnson 2017-07-07 14:22:33 EDT
Ievgen, is this a regression?  Was it working in 5.8.0?
Comment 4 Ievgen Zapolskyi 2017-07-07 16:25:21 EDT
Dave, it isn't regression. It was working before. 
Btw, I don't think it is related to Timelines.  I used such summary because I found steps which allow to 100% reproduce this issue.  
It seems there is one root cause for several BZs and the issue is either in accordion or details page.
Comment 7 Harpreet Kataria 2017-09-26 09:15:21 EDT
closing this BZ since it can no longer be reproduced.

~Harpreet

Note You need to log in before you can comment on or make changes to this bug.