Bug 1467646 - ose-pod pull fails when node is at 3.5.5.28
ose-pod pull fails when node is at 3.5.5.28
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.1
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 08:39 EDT by Javier Ramirez
Modified: 2017-08-24 13:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-24 13:15:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Ramirez 2017-07-04 08:39:33 EDT
Description of problem:

After deploying a new node, the openshift3/node:v3.5 image holds a reference to openshift3/ose-pod:v3.5.5.28. However, this tag does not exist on the Red Hat container registry (v3.5 refers to v3.5.5.26), resulting in the following error when trying to deploy the pod:
Error syncing pod, skipping: failed to "StartContainer" for "POD" with ImagePullBackOff: "Back-off pulling image \"openshift3/ose-pod:v3.5.5.28\""

Version-Release number of selected component (if applicable):
openshift3/node:v3.5.5.28

How reproducible:
Always

Steps to Reproduce:
1. Deploy a new containerized node
2. Try to run any new app on the new node


Actual results:
It fails with:
Error syncing pod, skipping: failed to "StartContainer" for "POD" with ImagePullBackOff: "Back-off pulling image \"openshift3/ose-pod:v3.5.5.28\""

Expected results:
Not sure if the problem is OpenShift needs to cater for discreet differences in                   version when starting, or all containers need to be released in sync

Additional info:
Customer implemented the following workaround:

docker pull openshift3/node;v3.5.5.26
docker tag openshift3/node:v3.5.5.26 openshift3/node:v3.5
systemctl restart atomic-openshift-node
Comment 4 Brenton Leanhardt 2017-08-24 13:15:57 EDT
This should be fixed with node:v3.5.5.31.

Note You need to log in before you can comment on or make changes to this bug.