Bug 1467667 - mariadb library upgrade to 10.2 causes tcl-mysqltcl FTBFS
mariadb library upgrade to 10.2 causes tcl-mysqltcl FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcl-mysqltcl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rene Ploetz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1467297
  Show dependency treegraph
 
Reported: 2017-07-04 09:39 EDT by Augusto Caringi
Modified: 2017-07-24 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 18:32:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow compilation of tcl-mysqltcl with MariaDB 10.2 (289 bytes, patch)
2017-07-04 09:39 EDT, Augusto Caringi
no flags Details | Diff

  None (edit)
Description Augusto Caringi 2017-07-04 09:39:49 EDT
Created attachment 1294215 [details]
Patch to allow compilation of tcl-mysqltcl with MariaDB 10.2

Trying to build tcl-mysqltcl with the new version of MariaDB 10.2 causes a build error:

./generic/mysqltcl.c:2320:7: error: too few arguments to function 'mysql_shutdown'
   if (mysql_shutdown(handle->connection)!=0) {
       ^~~~~~~~~~~~~~
In file included from ./generic/mysqltcl.c:43:0:
/usr/include/mysql/mysql.h:518:14: note: declared here
 int  STDCALL mysql_shutdown(MYSQL *mysql, enum mysql_enum_shutdown_level shutdown_level);
              ^~~~~~~~~~~~~~

I have attached a patch proposal to fix this error.

We are tracking all the possible problems regarding this MariaDB upgrade in the bug 1467297.

Copr build: https://copr.fedorainfracloud.org/coprs/g/db-sig/mariadb-10.2/package/tcl-mysqltcl/
Comment 1 Jason Taylor 2017-07-06 15:07:27 EDT
Thank you Augusto for the patch.

I don't see why we can implement it but will wait for Rene to chime in before doing so.

JT
Comment 2 Jason Taylor 2017-07-06 15:14:50 EDT
(In reply to Jason Taylor from comment #1)
> Thank you Augusto for the patch.
> 
> I don't see why we can implement it but will wait for Rene to chime in
> before doing so.
> 
> JT

Oops, I thought this was a package I maintain. Sorry, Rene will be the one to handle the updates.
Comment 3 Rene Ploetz 2017-07-20 13:45:21 EDT
Thanks for reporting. I will fix the problem in the next few days.
Comment 4 Rene Ploetz 2017-07-24 18:32:44 EDT
Turns out I did not need to apply the patch because the current rawhide version of mariadb contains a patch for https://jira.mariadb.org/browse/MDEV-13370 (which is causing the issues for this package), so I just did a version bump + rebuild.

See also https://koji.fedoraproject.org/koji/buildinfo?buildID=921593

Note You need to log in before you can comment on or make changes to this bug.