Bug 14677 - ATI Mach64 / Chrontel 8398A ISA Card Improperly Configured
ATI Mach64 / Chrontel 8398A ISA Card Improperly Configured
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-26 15:27 EDT by Dick Thompson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 20:46:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dick Thompson 2000-07-26 15:27:33 EDT
Xconfigurator, as well as xconfig from terminal windows, doesn't configure 
the subject 4 MB video card so that it works properly.

The card and monitor work fine with MS-DOS or Windows (any flavor).

The Red Hat X logon screen updates at a ghastly slow rate, wobbling and 
tearing, even with Linux supposedly set to use the card's basic 640 x 
480 "resolution". Serial mouse operation is impared. The Gnome desktop is 
unusable (virtually unreadable) due to tearing and wobbling.

Linux 6.2 and the monitor work just fine with an ATI Xpert@Work 8 MB PCI 
card at 800 x 600 resolution.

Current Linux 6.2 just flat doesn't properly configure ATI Mach 64 - 
Chrontel CH8398A 4 MB ISA "Graphics Xpressions" cards.
Comment 1 Trond Eivind Glomsrxd 2000-07-26 16:59:04 EDT
What does the /etc/X11/X point at, and what does the configuration file look
like?
Comment 2 Dick Thompson 2000-07-28 14:13:57 EDT
Sorry, but I can't tell you.

The only XF86 "driver" which I have found to work at all with the card is the 
generic XF86_SVGA. Using that module results in the behavior I described 
previously. Haven't tried the generic VGA module.

The unadorned straight VGA operation at the beginning of RH installation works 
fine, since I can get to the point of configuring XF86 in the RH Linux 6.2 
graphical installation process.

Attempting to install ANY of the ATI Mach64 - Chrontel modules results in a 
blank monitor display, regardless of the amount of memory specified or the 
display resolution selected, requiring a hardware reset of the machine to 
permit restart of the Linux installation process.

My suspicion is that the problem may have something to do with the "memory 
aperture" feature of the ATI Mach64GX chip which my board has. There is no 
jumper available on the board to enable or disable that feature. ATI claims the 
feature is "off" by default, and that special ATI software is required to turn 
the feature "on".

Additionally, there is no jumper to enable or disable the board's "fixed vs 
relocatable" video port addressing. "Relocatable" appears to be hardwired "on".

There are no jumpers on the board with which to set either IRQ or base address.

As noted before, the card works fine with Windows 98.

Thanks for your interest!

Comment 3 Dick Thompson 2000-07-28 14:14:40 EDT
Sorry, but I can't tell you.

The only XF86 "driver" which I have found to work at all with the card is the 
generic XF86_SVGA. Using that module results in the behavior I described 
previously. Haven't tried the generic VGA module.

The unadorned straight VGA operation at the beginning of RH installation works 
fine, since I can get to the point of configuring XF86 in the RH Linux 6.2 
graphical installation process.

Attempting to install ANY of the ATI Mach64 - Chrontel modules results in a 
blank monitor display, regardless of the amount of memory specified or the 
display resolution selected, requiring a hardware reset of the machine to 
permit restart of the Linux installation process.

My suspicion is that the problem may have something to do with the "memory 
aperture" feature of the ATI Mach64GX chip which my board has. There is no 
jumper available on the board to enable or disable that feature. ATI claims the 
feature is "off" by default, and that special ATI software is required to turn 
the feature "on".

Additionally, there is no jumper to enable or disable the board's "fixed vs 
relocatable" video port addressing. "Relocatable" appears to be hardwired "on".

There are no jumpers on the board with which to set either IRQ or base address.

As noted before, the card works fine with Windows 98.

Thanks for your interest!

Comment 4 Dick Thompson 2000-07-28 14:15:11 EDT
Sorry, but I can't tell you.

The only XF86 "driver" which I have found to work at all with the card is the 
generic XF86_SVGA. Using that module results in the behavior I described 
previously. Haven't tried the generic VGA module.

The unadorned straight VGA operation at the beginning of RH installation works 
fine, since I can get to the point of configuring XF86 in the RH Linux 6.2 
graphical installation process.

Attempting to install ANY of the ATI Mach64 - Chrontel modules results in a 
blank monitor display, regardless of the amount of memory specified or the 
display resolution selected, requiring a hardware reset of the machine to 
permit restart of the Linux installation process.

My suspicion is that the problem may have something to do with the "memory 
aperture" feature of the ATI Mach64GX chip which my board has. There is no 
jumper available on the board to enable or disable that feature. ATI claims the 
feature is "off" by default, and that special ATI software is required to turn 
the feature "on".

Additionally, there is no jumper to enable or disable the board's "fixed vs 
relocatable" video port addressing. "Relocatable" appears to be hardwired "on".

There are no jumpers on the board with which to set either IRQ or base address.

As noted before, the card works fine with Windows 98.

Thanks for your interest!
Comment 5 Trond Eivind Glomsrxd 2000-07-28 18:04:07 EDT
Can you try making /etc/X11/X point at /usr/X11R6/bin/XF86_MACH64 (make sure to
install it first) and create a standard XF86Config file with Xconfigurator?
Comment 6 Trond Eivind Glomsrxd 2000-08-04 15:08:11 EDT
Tried pinstripe with it?
Comment 7 Trond Eivind Glomsrxd 2000-08-15 18:43:53 EDT
Have you tried not specifying any clockchip?
Comment 8 Dick Thompson 2000-08-15 20:46:26 EDT
Sorry for the delay in answering! Been trying to get more detailed info than is 
available in the card manual from ATI.

Turns out this card is pseudo-PnP. Can't manually set IRQ or memory addresses 
with jumpers on the card.

Have tried installing with and without autoprobe and with and without 
specifying a clock chip - no dice.

Works - sort of - using generic VGA device driver for 640 x 480 pixel 
resolution. opaque moves are painfully slow.

Afraid I don't know what "pinstripe" is, nor how to use it.

Based on my few month's experience, it appears Linux doesn't support ISA PnP 
cards - of any variety - very well. Only cards I've had any success with are 
PCI - one Lucent-based winmodem, and one ATI PCI graphics card. My ISA sound, 
NIC and graphics cards just don't sem to be supported.

Thanks for your continuing interest. 

Dick Thompson
Comment 9 Trond Eivind Glomsrxd 2000-08-15 23:01:06 EDT
Pinstripe is the 7.0beta , which was released a couple of weeks ago.

I avent seen a ISA graphics card ever (my first PC in 93 had VESA localbus, the
PC I bought in 95 was PCI) but I don't think they use plug and play - I think
they are designed for a standard IRQ and IO so I would rule out that problem.
They would be rather slow (ISA is sloow and shared),  but you should get higher
resolutions at least. However, I think I'll close this with unsupported
hardware...
Hint for mobing on is looking for a way to turn of the memory aperture in the
BIOS.

Most ISA networking cards and some soundcardsshould work nice, though - try
sndconfig.
Comment 10 Dick Thompson 2000-08-16 12:56:51 EDT
I'm disappointed.

It's disingenuous for Red Hat to claim cards are "undupported" when both Red 
Hat's own "Hardware Compatibility Lists" and the XFree86 organization's Web 
sites claim ATI Mach64GX cards are indeed supported, with no disclaimers for 
ISA vs PCI, or ISA-jumpered versus ISA PnP.

Red Hat's own installer offers the option to install device drivers for these 
cards, again with no disclaimers.

Whether or not these cards are "old", Red Hat claims to support them.

Same for my old Ensonique Soundscape S2000. Red Hat's installer offers the 
option to install device drivers for it, but the device drivers loaded do not 
enable the card's MIDI functions.

I'd appreciate some honesty in advertising from Red Hat.

I realize you have no control over such matters, and I appreciate your help. 
Perhaps you will be good enough to pass my comments on to your marketeers and 
corporate heros. They need to understand that deceptive sales practices will, 
in the long run, sink them.

Thanks again for your own courteous, professional help!

Dick Thompson
Comment 11 Trond Eivind Glomsrxd 2000-08-16 13:12:35 EDT
I was more thinking of your BIOS  - the OS/2 hole between 15 and 16 MB needs to
be off. As for MIDI support for the Ensonic, I have no idea - I just develop
Xconfigurator(and quite a few other thing, but nothing sound-related). Read the
kernel docs for more information (/usr/src/linux/Documention/sound) for
limitations on the driver.

Have you tried looking around the net for information on your card? If you can
make a working configuration manually, it may be possible.

BTW: Does it crash your computer totally? (network included) when starting?

Note You need to log in before you can comment on or make changes to this bug.