This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1467862 - Inappropriate error info when creating internal snapshot for a vm only with a readonly disk
Inappropriate error info when creating internal snapshot for a vm only with a...
Status: CLOSED DUPLICATE of bug 1467859
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.5
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 07:08 EDT by jiyan
Modified: 2017-07-06 00:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-05 11:33:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jiyan 2017-07-05 07:08:14 EDT
Description of problem:
Inappropriate error info when creating internal snapshot for a domain only with a readonly disk


Version-Release number of selected component (if applicable):
libvirt-3.2.0-14.el7.x86_64
qemu-kvm-rhev-2.9.0-14.el7.x86_64
kernel-3.10.0-686.el7.x86_64


How reproducible:
100%


Steps to Reproduce:
1.Edit the vm's dumpxml as follows, the vm only with 1 disk element.
# virsh dumpxml rhel |grep "<disk" -A 8
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/rhel1.qcow2'/>
      <backingStore/>
      <target dev='sda' bus='scsi'/>
      <readonly/>
      <alias name='scsi0-0-0-0'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>


2.Start the vm
# virsh start rhel
Domain rhel started

# virsh -q list |grep rhel 
 8     rhel                           running


3.Create external snapshot for the vm
# virsh snapshot-create-as rhel ss --memspec snapshot=external,file=/tmp/s1 --diskspec sda,snapshot=external,file=/tmp/s2
error: internal error: unable to execute QEMU command 'transaction': Could not create file: Permission denied


4.Create internal snapshot for the vm
# virsh snapshot-create-as rhel 
error: unsupported configuration: internal snapshots and checkpoints require all disks to be selected for snapshot


Actual results:
As step4 above shows


Expected results:
As step3 above shows


Additional info:
Comment 2 Xuesong Zhang 2017-07-05 11:33:52 EDT

*** This bug has been marked as a duplicate of bug 1467859 ***

Note You need to log in before you can comment on or make changes to this bug.