Bug 146794 - system-config-printer-0.6.116.1-1.i386.rpm breaks cups
system-config-printer-0.6.116.1-1.i386.rpm breaks cups
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 168424
  Show dependency treegraph
 
Reported: 2005-02-01 12:37 EST by Hardy Mayer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEA-2006-0073
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:30:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output of printconf-tui --Xexport for the buggy version (10.51 KB, text/plain)
2005-02-02 11:33 EST, Hardy Mayer
no flags Details
Diffs between ther outpu of buggy version, and the previous version (3.26 KB, text/plain)
2005-02-02 11:35 EST, Hardy Mayer
no flags Details
tail of /var/locgcups/error_log (115.50 KB, text/plain)
2005-02-02 12:11 EST, Hardy Mayer
no flags Details
cupsd.conf modified with debug2 (23.48 KB, text/plain)
2005-02-02 12:34 EST, Hardy Mayer
no flags Details

  None (edit)
Description Hardy Mayer 2005-02-01 12:38:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I updated to system-config-printer-0.6.116.1-1.i386.rpm  from 
system-config-printer-0.6.116.1 and 
1. After editing a printer and trying to "apply," Printtool comes up
with the message "Failed to write queues"

2. Cups is stopped and cannot be restarted:

#/etc/init.d/cups start
Starting cups: cupsd: Child exited with status 98!
                                                           [FAILED]


Reverting to system-config-printer-0.6.116.1.i386.rpm  fixes the problem. 
I am running Kernel  2.6.10-1.741_FC3. 

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116.1-1.i386.rpm 

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh system-config-printer-0.6.116.1-1.i386.rpm 
2. system-config-printer
3. Edit a queue and try to "Apply"
    

Actual Results:  "Failed to write queues"
cups is dead

The messages log lists, as expected:
Feb  1 09:20:44 hardy cups: cupsd shutdown succeeded
Feb  1 09:20:47 hardy cupsd: cupsd: Child exited with status 98!
Feb  1 09:20:47 hardy cups: cupsd startup failed
Feb  1 09:23:09 hardy cups: cupsd shutdown failed
Feb  1 09:23:10 hardy cups: cupsd shutdown failed
Feb  1 09:23:11 hardy cupsd: cupsd: Child exited with status 98!
Feb  1 09:23:11 hardy cups: cupsd startup failed
Feb  1 09:23:40 hardy cupsd: cupsd: Child exited with status 98!
Feb  1 09:23:40 hardy cups: cupsd startup failed
Feb  1 09:25:21 hardy cups: cupsd shutdown failed
Feb  1 09:25:22 hardy cups: cupsd shutdown failed
Feb  1 09:25:23 hardy cupsd: cupsd: Child exited with status 98!
Feb  1 09:25:23 hardy cups: cupsd startup failed

Expected Results:  cups to work with the new settings

Additional info:

rpm --force -Uvh system-config-printer-0.6.116-1.i386.rpm  
system-config-printer-gui-0.6.116-1.i386.rpm
brings things back to normal!
Comment 1 Hardy Mayer 2005-02-01 12:40:27 EST
Forgot to mention: the cups version is
cups-1.1.22-0.rc1.8.4
Comment 2 Tim Waugh 2005-02-02 09:43:39 EST
Please attach the output of 'printconf-tui --Xexport', making sure to replace
any passwords for remote queues with '***'.  Thanks.
Comment 3 Hardy Mayer 2005-02-02 10:30:19 EST
I will need to reinstall the buggy version for this, when I have some free time. 
Comment 4 Hardy Mayer 2005-02-02 11:33:30 EST
Created attachment 110553 [details]
The output of printconf-tui --Xexport for the buggy version
Comment 5 Hardy Mayer 2005-02-02 11:35:00 EST
Created attachment 110554 [details]
Diffs between ther outpu of buggy version, and the previous version
Comment 6 Tim Waugh 2005-02-02 11:38:30 EST
Thanks.  Now can you please set the LogLevel in /etc/cups/cupsd.conf to
'debug2', and then cause the error to happen using system-config-printer.  Then
attach the relevant bit of /var/log/cups/error_log (if you truncate it first
with '>/var/log/cups/error_log' on the shell command line it will only contain
the relevant bits).

Thanks.
Comment 7 Hardy Mayer 2005-02-02 12:11:50 EST
Created attachment 110559 [details]
tail of /var/locgcups/error_log
Comment 8 Tim Waugh 2005-02-02 12:18:28 EST
Please attach /etc/cups/cupsd.conf.
Comment 9 Hardy Mayer 2005-02-02 12:34:01 EST
Created attachment 110560 [details]
cupsd.conf modified with debug2
Comment 10 Hardy Mayer 2005-02-02 12:35:27 EST
I tried to replace cupsd.con (as sent) with cupsd.conf.rpmnew -- same result. 
Comment 11 Hardy Mayer 2005-02-02 13:15:48 EST
I just reinstalled the working system-config-printer and noticed that the
permissions on /etc/cups/cupsd.conf differ: 
In the nonworking version: 

-rw-------   1 lp   sys    21429 Feb  2 10:08 cupsd.conf

In the working version 
-rw-r-----   1 root sys    20799 Feb  2 10:11 cupsd.conf

Could this be the cause of the failure? 
Comment 12 Tim Waugh 2005-02-02 13:24:34 EST
No, it's not to do with that.  The bug is actually present in the original
system-config-printer as well, but luck prevents it from showing up.

Thank you very much for reporting this.
Comment 13 Hardy Mayer 2005-02-02 14:11:03 EST
I am surprised no one else reported this.
I had a hard time (trying various cupsd.conf files) to 
get a cups version which works!
Comment 14 Tim Waugh 2005-02-03 06:43:47 EST
It's quite a specific configuration that causes it: you have to have one printer
shared by "eth0", and another shared by a particular IP address available via
that interface -- and they have to be processed in a particular order.

What changed in the update was the order that some of the queues are processed.

An update to fix this is coming soon, but I need to investigate another bug
report first.
Comment 19 Tim Waugh 2005-08-02 12:18:21 EDT
Also affects RHEL3.
Comment 27 Red Hat Bugzilla 2006-03-15 10:30:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2006-0073.html

Note You need to log in before you can comment on or make changes to this bug.