Bug 1467984 - using deployer's uninstall mode does not clean up all resources created during the installation for OCP <= 3.4
using deployer's uninstall mode does not clean up all resources created durin...
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Logging (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Cantrill
Xia Zhao
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 13:48 EDT by Peter Ruan
Modified: 2017-07-06 14:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 14:32:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2017-07-05 13:48:35 EDT
Description of problem:
using deployer's uninstall mode does not clean up all resources created during the installation for OCP <= 3.4 
I still need to do 
'oc delete oauthclients kibana-proxy && oc delete clusterrole oauth-editor daemonset-admin rolebinding-reader' in order to completely remove all resources created by the installation step.


Version-Release number of selected component (if applicable):
<= 3.4

How reproducible:
always

Steps to Reproduce:
1. install logging via deployer following steps here https://docs.openshift.com/container-platform/3.4/install_config/aggregate_logging.html
2. uninstall via oc new-app logging-deployer-template --param MODE=uninstall
3. try to create logging again using steps #1, it will fail due to the fact that clusteroles exists.

Actual results:--> Creating resources ...
    service "logging-es" created
    service "logging-es-cluster" created
    service "logging-es-ops" created
    service "logging-es-ops-cluster" created
    service "logging-kibana" created
    service "logging-kibana-ops" created
--> Failed
    error: oauthclients "kibana-proxy" already exists


Expected results:


Additional info:
Comment 2 Jeff Cantrill 2017-07-06 14:32:54 EDT
Closing as we are only patching critical changes to the deployer since it has been replaced by openshift-ansible.  The work around is to manually remove the items which were not deleted.

Note You need to log in before you can comment on or make changes to this bug.