Bug 1468045 - acme-tiny needs patch for change in openssl output
acme-tiny needs patch for change in openssl output
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: acme-tiny (Show other bugs)
26
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Stuart D Gathman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 17:28 EDT by Ed Marshall
Modified: 2017-09-06 10:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: acme-tiny-0.2-1.20170516gitaf025f5.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 10:52:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Marshall 2017-07-05 17:28:50 EDT
OpenSSL changed the CN output formatting with the release of 1.1. acme-tiny parses this formatting, and the version shipping in Fedora isn't resilient to the change. So, renewals will fail.

Upstream has applied the following patch, which is working for me right now: 

https://github.com/diafygi/acme-tiny/commit/9537453586cd5124d5e4e46d78f9ed909180835d

Might be a good time to re-sync with upstream?
Comment 1 Stuart D Gathman 2017-07-06 20:01:30 EDT
I'm moving to this commit:

https://github.com/diafygi/acme-tiny/commit/af025f5bf19c70be7fafab67f4dd718ca7bf9adf
Comment 2 Fedora Update System 2017-07-06 21:48:49 EDT
acme-tiny-0.2-1.20170516gitaf025f5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5773468f36
Comment 3 Fedora Update System 2017-07-08 22:53:16 EDT
acme-tiny-0.2-1.20170516gitaf025f5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5773468f36
Comment 4 Stuart D Gathman 2017-09-05 22:29:34 EDT
This change broke python2.  It works in F26 because python3 is used by default.
Comment 5 Fedora Update System 2017-09-06 10:52:11 EDT
acme-tiny-0.2-1.20170516gitaf025f5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.