Bug 146806 - unknown opcodes and card state dumps
unknown opcodes and card state dumps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 13:56 EST by Zing
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-19 00:53:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (11.12 KB, text/plain)
2005-02-01 13:58 EST, Zing
no flags Details
cdrecord run that worked (1.10 KB, text/plain)
2005-02-16 17:28 EST, Zing
no flags Details
here's the real attachment DOH (3.32 KB, text/plain)
2005-02-16 17:30 EST, Zing
no flags Details
full dmesg log (2.6.13) (28.38 KB, text/plain)
2005-10-03 15:38 EDT, Zing
no flags Details
lspci -vv (7.60 KB, text/plain)
2005-10-03 15:39 EDT, Zing
no flags Details

  None (edit)
Description Zing 2005-02-01 13:56:23 EST
Description of problem:
machine has adaptec AIC-7861 and plexwriter 40/12/40S

running cdrecord causes all types of kernel messages. ultimately
burning fails...

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.753_FC3
cdrecord-2.01.1-5

How reproducible:
always

Steps to Reproduce:
1. cdrecord dev=/dev/scd0 -data burn.iso
  
Actual results:
unknown opcodes and card dump states...

snippet:
scsi: unknown opcode 0xe9
scsi: unknown opcode 0xed
scsi: unknown opcode 0x01
scsi: unknown opcode 0xeb

Expected results:
able to burn

Additional info:
i'll attach more of the dmesg.  I think this report belongs in kernel,
but I'm not quite sure... thanks
Comment 1 Zing 2005-02-01 13:58:02 EST
Created attachment 110513 [details]
dmesg log
Comment 2 Zing 2005-02-16 17:28:05 EST
ok, the scsi card is really a 2940A Ultra card.  Sorry about that... so I tried
the aic7xxx_old driver and I still get unknown opcodes and a bunch of new type
of errors such as data overruns detected, BUT I can actually burn a cd now and
it works.

i guess this isn't so much an issue untill the _old driver goes away.
Comment 3 Zing 2005-02-16 17:28:57 EST
Created attachment 111143 [details]
cdrecord run that worked
Comment 4 Zing 2005-02-16 17:30:26 EST
Created attachment 111144 [details]
here's the real attachment DOH

sorry about that, here's the real log...
Comment 5 Dave Jones 2005-07-15 13:40:06 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Zing 2005-08-01 11:54:53 EDT
fc4, 1398 kernel, aic7xxx, still fails in the same way as in comment #1.  (A
firmware update to 1.05 of the cdrw didn't help.)
Comment 7 Aaron Kaplan 2005-08-15 10:20:59 EDT
I get the following uknown opcode errors when burning with cdrecord on an ATAPI
Plexwriter 24/10/40A with kernel-2.6.12-1.1398_FC4.  It's the same as reported
above, plus 0xF5.

kernel: scsi: unknown opcode 0xe9
kernel: scsi: unknown opcode 0xed
kernel: scsi: unknown opcode 0x01
kernel: scsi: unknown opcode 0xf5
kernel: scsi: unknown opcode 0xeb

The burn fails, and cdrecord hangs and can't be killed.
Comment 8 Dave Jones 2005-09-30 02:08:48 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Zing 2005-10-03 15:36:52 EDT
still fails with 2.6.13-1.1526_FC4.  I'll attach a new full dmesg log and an
lspci  dump
Comment 10 Zing 2005-10-03 15:38:24 EDT
Created attachment 119562 [details]
full dmesg log (2.6.13)
Comment 11 Zing 2005-10-03 15:39:04 EDT
Created attachment 119563 [details]
lspci -vv
Comment 12 Aaron Kaplan 2005-10-09 04:57:31 EDT
I confirm that this has not been fixed by 2.6.13-1.1526_FC4.
Comment 13 Dave Jones 2005-11-10 14:07:00 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 14 Aaron Kaplan 2005-11-12 07:31:30 EST
Under 2.6.14-1.1637_FC4 the "unknown opcode" messages still appear in the log,
but I am able to burn a CD again.
Comment 15 Zing 2005-11-14 10:43:59 EST
Confirmed! Under 2.6.14-1.1637_FC4 I can burn cds again.  My logs are very clean
too... no "unknown opcode" messages showed up for my setup.
Comment 16 Dave Jones 2006-02-03 00:13:13 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 17 Zing 2006-02-06 09:44:00 EST
Unfortunately, I no longer have the hardware to test the cd writing under
2.6.15.  In case you missed my note in #15, it worked fine under
2.6.14-1.1637_FC4.  

Note You need to log in before you can comment on or make changes to this bug.