Bug 1468246 - Installing openstack-kolla fails because of broken upgrade path in python-docker
Installing openstack-kolla fails because of broken upgrade path in python-docker
Status: NEW
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Alfredo Moralejo
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 08:57 EDT by Alfredo Moralejo
Modified: 2017-07-07 17:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Moralejo 2017-07-06 08:57:49 EDT
Description of problem:

When running yum update in a system with python-docker-py and python-docker-pycreds installed from centos extra repo, it fails with following messages:

2017-07-05 06:16:09 | 2017-07-05 06:16:09,835 INFO: [1;31mError: Execution of '/bin/yum -d 0 -e 0 -y install openstack-kolla' returned 1: Transaction check error:
2017-07-05 06:16:09 | 2017-07-05 06:16:09,836 INFO:   file /usr/lib/python2.7/site-packages/docker_pycreds-0.2.1-py2.7.egg-info/requires.txt from install of python2-docker-pycreds-0.2.1-4.el7.noarch conflicts with file from package python-docker-pycreds-1.10.6-1.el7.noarch
2017-07-05 06:16:09 | 2017-07-05 06:16:09,836 INFO:   file /usr/lib/python2.7/site-packages/docker/__init__.py from install of python2-docker-2.3.0-1.1.el7.noarch conflicts with file from package python-docker-py-1.10.6-1.el7.noarch


Version-Release number of selected component (if applicable):

python2-docker-2.3.0-1.1.el7.noarch

How reproducible:

Always

Steps to Reproduce:
1. In a CentOS system install python-docker-py

yum install python-docker-py python-docker-pycreds

2. Configure rdo trunk master repo:

cd /etc/yum.repos.d
wget http://trunk.rdoproject.org/centos7/delorean-deps.repo
wget http://trunk.rdoproject.org/centos7/current-passed-ci/delorean.repo

3. Try to instll openstack-kolla

Actual results:

Installation fails with conflict errors

Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.