Bug 146834 - cannot import module Conf
cannot import module Conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 18:23 EST by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 10:48:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2005-02-01 18:23:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have a system inbetween FC3 and devel. I get the following traceback:

[root@chapelle ~]# system-config-bind
ImportError: could not import bonobo.ui
Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 37, in ?
    from BIND import *
  File "/usr/share/system-config-bind/BIND.py", line 12, in ?
    import Lookup
  File "/usr/share/system-config-bind/Lookup.py", line 16, in ?
    from   Hosts import Hosts
  File "/usr/share/system-config-bind/Hosts.py", line 12, in ?
    from Conf import *
ImportError: No module named Conf


Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-3

How reproducible:
Always

Steps to Reproduce:
1. run system-config-bind
2.
3.
    

Actual Results:  a traceback

Expected Results:  something else

Additional info:

I was hit by bug #146475, and therefore used the rpm indicated there
to test.
Comment 1 Jason Vas Dias 2005-02-01 18:45:10 EST
This is probably because of a mixup with python / rhpl versions.

1. You must have the 'rhpl' package installed  :
   # rpm -q rhpl
rhpl-0.148-1-2

2. If you have python2.4 installed, (probably a bad idea unless
   you have a completely up2date FC4 system) you must upgrade / 
   reinstall rhpl (and all packages that use python) so that its
   package files are in 
   /usr/lib/python2.4/site-packages/rhpl

   Otherwise, if you have only the directory:
   /usr/lib/python2.3/site-packages/rhpl
   when running system-config-bind, do:
   # mv /usr/bin/python /usr/bin/python2.4
   # mv /usr/bin/python2.3 /usr/bin/python
     Then system-config-bind should run OK .

ie. system-config-bind runs fine when either:
    - python2.3 only is installed
  or
    - python2.4 is installed and ALL PYTHON PACKAGES 
      are upgraded to use python2.4 .
  
  but not if you are in between these situations.
Comment 2 Jason Vas Dias 2005-02-04 10:48:50 EST
I think this problem is due to a misconfiguration of the system
and is not a system-config-bind bug.
Comment 3 Patrice Dumas 2005-02-05 08:54:47 EST
I wouldn't call that a misconfiguration. It seems to me that that's a
bug in either the packaging tools or the packages. I may be wrong but
my understanding was that the rpm tool allowed to have the right
dependancies installed. Here it is not the case. Otherwise said, the
following should be handled by the packaging system:

2. If you have python2.4 installed, (probably a bad idea unless
   you have a completely up2date FC4 system) you must upgrade / 
   reinstall rhpl (and all packages that use python) so that its
   package files are in 
   /usr/lib/python2.4/site-packages/rhpl

Indeed either I shouldn't be able to have python2.4 installed, with
python packages from FC3, or the packages should be upgraded. But this
should be left to the packaging tools and not by me. I think it isn't
NOTABUG. It may be a wontfix, something like "there are broken
dependancies, but we don't want to fix it because these dependancies
issues will be fixed in FC4", or "because you'll be hit only if you
upgrade some cluster of packages by hand and an anaconda install or an
update of the whole system are the only upgrade path targets", or
"this is a shortcoming in the packaging system allready reported as
bug ....", but this is definitely a bug in my opinion.

Note You need to log in before you can comment on or make changes to this bug.