Bug 1468392 - darktable crashes on startup in fedora 26 beta
darktable crashes on startup in fedora 26 beta
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beignet (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
: Reopened
: 1468977 1469023 1470161 1470876 1471072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 19:55 EDT by Bill
Modified: 2017-07-16 16:21 EDT (History)
10 users (show)

See Also:
Fixed In Version: beignet-1.3.1-3.git20170622.36f6a8b.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-16 16:21:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.36 KB, text/plain)
2017-07-14 13:07 EDT, Andrew Aylett
no flags Details

  None (edit)
Description Bill 2017-07-06 19:55:58 EDT
Description of problem:

darktable fails to start on fedora 26 beta


Version-Release number of selected component (if applicable): 2.2.5-2.fc26


How reproducible: Launch darktable from GUI or command line.


Actual results:

darktable
darktable: /usr/include/llvm/Support/Casting.h:236: typename llvm::cast_retty<X, Y*>::ret_type llvm::cast(Y*) [with X = llvm::CompositeType; Y = llvm::Type; typename llvm::cast_retty<X, Y*>::ret_type = llvm::CompositeType*]: Assertion `isa<X>(Val) && "cast<Ty>() argument of incompatible type!"' failed.
Aborted (core dumped)



Expected results:

darktable starts normally


Additional info:

Desktop is gnome on xorg (not wayland).
Comment 1 Germano Massullo 2017-07-07 05:33:44 EDT
Please uninstall beignet and/or pocl buggish OpenCL driver
Comment 2 Bill 2017-07-07 10:00:21 EDT
Confirmed - removing package beignet resolved the issue.
Comment 3 Germano Massullo 2017-07-10 03:49:02 EDT
*** Bug 1468977 has been marked as a duplicate of this bug. ***
Comment 4 Germano Massullo 2017-07-12 10:04:09 EDT
*** Bug 1470161 has been marked as a duplicate of this bug. ***
Comment 5 Germano Massullo 2017-07-12 10:04:28 EDT
*** Bug 1469023 has been marked as a duplicate of this bug. ***
Comment 6 Jaroslav Hůna 2017-07-12 11:04:41 EDT
Confirmed - removing beignet allows Darktable to launch. Thank you all.
Comment 7 Germano Massullo 2017-07-14 02:52:53 EDT
*** Bug 1470876 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2017-07-14 05:44:16 EDT
beignet-1.3.1-3.git20170622.36f6a8b.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
Comment 9 Daniel Berrange 2017-07-14 06:36:51 EDT
*** Bug 1470876 has been marked as a duplicate of this bug. ***
Comment 10 Germano Massullo 2017-07-14 06:47:46 EDT
*** Bug 1471072 has been marked as a duplicate of this bug. ***
Comment 11 Germano Massullo 2017-07-14 07:21:18 EDT
(In reply to Fedora Update System from comment #8)
> beignet-1.3.1-3.git20170622.36f6a8b.fc26 has been submitted as an update to
> Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c

You may want to test and leave karma feedback to new beignet update
https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
Keep in mind that beignet is blacklisted in darktable, so it is not used, but the new update will prevent other users from getting crashes while darktable looks for OpenCL devices/drivers on startup
Comment 12 Berwyn Powell 2017-07-14 07:40:00 EDT
(In reply to Germano Massullo from comment #11)
> You may want to test and leave karma feedback to new beignet update
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
> Keep in mind that beignet is blacklisted in darktable, so it is not used,
> but the new update will prevent other users from getting crashes while
> darktable looks for OpenCL devices/drivers on startup

I've tested the beignet update on my system and can confirm that with it installed Darktable and Blender no longer crash on startup.
Comment 13 Germano Massullo 2017-07-14 07:41:34 EDT
(In reply to Berwyn Powell from comment #12)
> (In reply to Germano Massullo from comment #11)
> > You may want to test and leave karma feedback to new beignet update
> > https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
> > Keep in mind that beignet is blacklisted in darktable, so it is not used,
> > but the new update will prevent other users from getting crashes while
> > darktable looks for OpenCL devices/drivers on startup
> 
> I've tested the beignet update on my system and can confirm that with it
> installed Darktable and Blender no longer crash on startup.

Can you vote here -> https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
Thank you
Comment 14 Berwyn Powell 2017-07-14 08:02:09 EDT
(In reply to Germano Massullo from comment #13)
> Can you vote here ->
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
> Thank you

I have done already, but for some reason my comment is listed as anonymous. Thanks so much to the Fedora team for acting on this one so quickly.
Comment 15 Germano Massullo 2017-07-14 08:07:24 EDT
(In reply to Berwyn Powell from comment #14)
> (In reply to Germano Massullo from comment #13)
> > Can you vote here ->
> > https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
> > Thank you
> 
> I have done already, but for some reason my comment is listed as anonymous.
> Thanks so much to the Fedora team for acting on this one so quickly.

Anonymouse votes do not count for automated pushing to stable repo, please login to bodhi
Comment 16 Andrew Aylett 2017-07-14 13:07:08 EDT
Similar problem has been detected:

Starting darktable with OpenCL support enabled causes it to crash; passing --disable-opencl lets it start normally.

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/darktable
crash_function: llvm::cast<llvm::CompositeType, llvm::Type>
executable:     /usr/bin/darktable
journald_cursor: s=e100b86a3e88478fa03f98793df8fc1a;i=7a15;b=fa06d9f7ff334422b0034533ea872655;m=2e07a27c7;t=554444fcfb2f2;x=b1cd3656eed59d57
kernel:         4.11.8-200.fc25.x86_64
package:        darktable-2.2.5-2.fc26
reason:         darktable killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 17 Andrew Aylett 2017-07-14 13:07:14 EDT
Created attachment 1298526 [details]
File: backtrace
Comment 18 Germano Massullo 2017-07-14 13:17:14 EDT
(In reply to Andrew Aylett from comment #16)
> Similar problem has been detected: [...]

Please do read https://bugzilla.redhat.com/show_bug.cgi?id=1468392#c11
Comment 19 Fedora Update System 2017-07-14 18:56:38 EDT
beignet-1.3.1-3.git20170622.36f6a8b.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-10cd9f1c4c
Comment 20 Fedora Update System 2017-07-16 16:21:46 EDT
beignet-1.3.1-3.git20170622.36f6a8b.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.