Bug 1468625 - [pci]/alias option is not present in the nova configuration on the computes
[pci]/alias option is not present in the nova configuration on the computes
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eoghan Glynn
awaugama
scale_lab, aos-scalability-36
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 10:56 EDT by Sai Sindhur Malleni
Modified: 2017-07-21 09:44 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 09:43:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1702730 None None None 2017-07-07 10:59 EDT

  None (edit)
Description Sai Sindhur Malleni 2017-07-07 10:56:15 EDT
Description of problem:
[pci]/alias option is not being configured by the compute manifest. This option is needed in the nova configuration file on compute nodes starting with Ocata. It is instead being configured by the nova::api class when it should havebeen configured by nova::compute.


Version-Release number of selected component (if applicable):
11

How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ollie Walsh 2017-07-07 11:04:41 EDT
Assigning to openstack-nova for now until we determine conclusively where the pci passthough conf should be done (compute config vs scheduler config vs both)
Comment 3 Sai Sindhur Malleni 2017-07-17 09:06:48 EDT
Seems like [pci]/alias option is needed on the controllers. On removing [pci]/alias from the controllers, restarting the nova services and trying to launch an instance with the alias in flavor I see PCI alias nvme is not defined (HTTP 400) . However, I have not confirmed if [pci]/alias is needed on the compute nodes.

Link to Error: https://gist.github.com/smalleni/e84c6955675445adf1f750dc7a8eb01a#file-gistfile1-txt-L1
Comment 4 Sahid Ferdjaoui 2017-07-17 09:30:21 EDT
The are two important options related to PCI; passthrought_whitelist and alias.

The passthrought_whitelist is related to the hardwares installed on the compute hosts. There is nothing in relation with the controllers. In the case you find a relation you should open a bug report.

The alias is related to the API, it provides an easy way for users to request hardwares. That option should only be relevant in the controllers.
Comment 5 Ollie Walsh 2017-07-21 09:43:36 EDT
Based on Sahid's comment, which was my expectation after briefly reviewing the code, I'll close this as not a bug. However we should correct the (upstream?) docs the mention setting pci alias on the computes.

Note You need to log in before you can comment on or make changes to this bug.