Bug 146871 - apxs does not honour CC and CFLAGS environment variables
apxs does not honour CC and CFLAGS environment variables
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 07:06 EST by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 07:08:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2005-02-02 07:06:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
apxs ignores CC and CFLAGS

Version-Release number of selected component (if applicable):
httpd-devel-2.0.52-3.1

How reproducible:
Always

Steps to Reproduce:
1. CC=ffff /usr/sbin/apxs -i -a -c foo.c
2.
3.
    

Actual Results:  /bin/sh /usr/lib/apr/build/libtool --silent
--mode=compile gcc -prefer-pic -O2 -g -pipe -m32 -march=i386
-mtune=pentium4 -DAP_HAVE_DESIGNATED_INITIALIZER -DLINUX=2
-D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/apr-0
-I/usr/include/httpd  -c -o mod_spambot.lo mod_spambot.c && touch
mod_spambot.slo


Expected Results:  /bin/sh /usr/lib/apr/build/libtool --silent
--mode=compile ffff -prefer-pic -O2 -g -pipe -m32 -march=i386
-mtune=pentium4 -DAP_HAVE_DESIGNATED_INITIALIZER -DLINUX=2
-D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/apr-0
-I/usr/include/httpd  -c -o mod_spambot.lo mod_spambot.c && touch
mod_spambot.slo


Additional info:
Comment 1 Joe Orton 2005-02-02 07:08:12 EST
This is working as intended; apxs will ensure that the module is
compiled with the same $CC setting as httpd itself.  You can pass
extra $CFLAGS to apxs without issue, just on the command-line not via
the environment.

Note You need to log in before you can comment on or make changes to this bug.