Bug 1468809 - Dnf install yields dependency error for botan-devel and openssl-devel
Dnf install yields dependency error for botan-devel and openssl-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: botan (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-08 05:15 EDT by Georg Sauthoff
Modified: 2017-07-23 06:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-23 06:49:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georg Sauthoff 2017-07-08 05:15:20 EDT
Description of problem:

I can't install botan-devel and openssl-devel together.


Version-Release number of selected component (if applicable):

How reproducible:

always

Steps to Reproduce:
1. dnf install botan-devel openssl-devel
2.
3.

Actual results:

Last metadata expiration check: 0:45:13 ago on Sat 08 Jul 2017 08:25:43 AM UTC.
Error: 
 Problem: package botan-devel-1.10.14-5.fc26.i686 requires compat-openssl10-devel, but none of the providers can be installed
  - package compat-openssl10-devel-1:1.0.2j-6.fc26.i686 conflicts with openssl-devel provided by openssl-devel-1:1.1.0f-4.fc26.i686
  - package compat-openssl10-devel-1:1.0.2j-6.fc26.x86_64 conflicts with openssl-devel provided by openssl-devel-1:1.1.0f-4.fc26.i686
  - conflicting requests
  - package compat-openssl10-devel-1:1.0.2j-6.fc26.i686 conflicts with openssl-devel provided by openssl-devel-1:1.1.0f-4.fc26.x86_64
  - package compat-openssl10-devel-1:1.0.2j-6.fc26.x86_64 conflicts with openssl-devel provided by openssl-devel-1:1.1.0f-4.fc26.x86_64
  - package botan-devel-1.10.14-5.fc26.x86_64 requires compat-openssl10-devel, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstalable packages)

Expected results:

Install of botan-devel and openssl-devel without errors.

Additional info:

Current Fedora 26 beta system - custom-environment package group is installed.

It is a x86-64 system - installed with x86-64 packages. Thus, I am surprised that dnf even considers i686 packages for the above command.

Installing with --enablerepo=updates-testing yields a similar error.
Comment 1 Thomas Moschny 2017-07-23 06:49:06 EDT
You can install botan-devel or openssl-devel, but not both. This is caused by  the fact that botan-devel requires compat-openssl10-devel, which in turn conflicts with openssl-devel.

You will get similar output from dnf when trying to install compat-openssl10-devel and openssl-devel together.

If you think dnf's output is not clear enough, please open a ticket for dnf ;)

Note You need to log in before you can comment on or make changes to this bug.