Bug 1468841 - Symbol versioning problem between efivar and efibootmgr.
Symbol versioning problem between efivar and efibootmgr.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: efibootmgr (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-08 15:43 EDT by Peter Jones
Modified: 2017-07-16 16:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: efibootmgr-15-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-16 16:20:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Jones 2017-07-08 15:43:32 EDT
Description of problem: Some efibootmgr operations don't work right because of a linker symbol versioning problem:

[root@random ~]# efibootmgr -b 0003 -B
efibootmgr: relocation error: efibootmgr: symbol efi_error_set, version LIBEFIVAR_1.28 not defined in file libefivar.so.1 with link time reference

Version-Release number of selected component (if applicable): efibootmgr-14-3
Comment 1 Fedora Update System 2017-07-08 16:39:54 EDT
efivar-31-1.fc26 efibootmgr-15-1.fc26 dbxtool-7-4.fc26 fwupdate-8-4.fc26 mokutil-0.3.0-5.fc26 pesign-0.112-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-45b006e169
Comment 2 Fedora Update System 2017-07-12 04:35:17 EDT
dbxtool-7-4.fc26, efibootmgr-15-1.fc26, efivar-31-1.fc26, fwupdate-8-4.fc26, mokutil-0.3.0-5.fc26, pesign-0.112-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-45b006e169
Comment 3 Fedora Update System 2017-07-16 16:20:20 EDT
dbxtool-7-4.fc26, efibootmgr-15-1.fc26, efivar-31-1.fc26, fwupdate-8-4.fc26, mokutil-0.3.0-5.fc26, pesign-0.112-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.