Bug 1469032 - Fedora 25 upgrade to Fedora 26 needs allowerasing because of lz4
Fedora 25 upgrade to Fedora 26 needs allowerasing because of lz4
Status: CLOSED DUPLICATE of bug 1468821
Product: Fedora
Classification: Fedora
Component: lz4 (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pjp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 06:08 EDT by František Zatloukal
Modified: 2017-07-11 06:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 05:49:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Removing lz4 on Fedora 25 (7.24 KB, text/plain)
2017-07-10 06:09 EDT, František Zatloukal
no flags Details
Upgrade with --allowerasing works fine (743 bytes, text/plain)
2017-07-10 06:09 EDT, František Zatloukal
no flags Details

  None (edit)
Description František Zatloukal 2017-07-10 06:08:09 EDT
Description of problem:
# dnf system-upgrade download --refresh --releasever=26
fails because of lz4-1.7.5-1.fc25.i686. Removing this package in Fedora 25 would result in removing lot of other packages too (see attached f25_remove_lz4.log ). On the other hand, upgrading with --allowerasing will remove lz4-1.7.5-1.fc25.i686 but not other packages (f25_26_allowerasing.log).

Version-Release number of selected component (if applicable):
lz4-1.7.5-1.fc25.i686
dnf-1.1.10-6.fc25.noarch
dnf-plugin-system-upgrade-0.7.1-4.fc25.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install lz4-1.7.5-1.fc25.i686
2. Try dnf system-upgrade download --refresh --releasever=26


Expected results:
Upgrading should work without --allowerasing.

Additional info:
I don't know Gnome Software upgrade behaviour in these cases, it might not work correctly?
Comment 1 František Zatloukal 2017-07-10 06:09 EDT
Created attachment 1295762 [details]
Removing lz4 on Fedora 25
Comment 2 František Zatloukal 2017-07-10 06:09 EDT
Created attachment 1295763 [details]
Upgrade with --allowerasing works fine
Comment 3 Kamil Páral 2017-07-11 05:47:48 EDT
It seems lz4 used to be multilib and now it isn't, and that's why i686 version needs to be erased. I'm not sure if there's something that can be done using obsoletes that would improve this experience.
Comment 4 Igor Gnatenko 2017-07-11 05:49:58 EDT
One should really search when submitting new bugs...

*** This bug has been marked as a duplicate of bug 1468821 ***
Comment 5 František Zatloukal 2017-07-11 06:09:44 EDT
(In reply to Igor Gnatenko from comment #4)
> One should really search when submitting new bugs...
> 
> *** This bug has been marked as a duplicate of bug 1468821 ***

I don't see what is duplicated here. The bug you've linked as duplicate is about "Old version of lz4 remains installed after upgrade" and that is further duplicate of "Upgrade is not working". This one is about "One should not need to run upgrade with --allowerasing". 

Difference is clear if you read Expected results section in this  report...

Note You need to log in before you can comment on or make changes to this bug.