Bug 1469033 - [atomic registry] Deleted project is still on Overview/Projects page till page refresh
[atomic registry] Deleted project is still on Overview/Projects page till pag...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Registry Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Peter
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 06:10 EDT by Xingxing Xia
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version: cockpit-147-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 17:09:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xingxing Xia 2017-07-10 06:10:21 EDT
Description of problem:
Deleted project is still on Overview/Projects page till page refresh. Go to "Projects" page and delete it again, it prompt the project creator: cannot delete projects in project "xxia-proj".
After explicit page refresh, the project is not shown, though. But user is confused if user does not imagine to use fresh.

Version-Release number of selected component (if applicable):
OCP v3.6.138
registry console image (cockpit 141-3):
brew-.../registry-console      v3.6                5cfa3998f500        2 hours ago         219.9 MB

How reproducible:
Always

Steps to Reproduce:
1. Login to registry console, create project xxia-proj
2. Go to Projects page, delete the project, then go to Overview again, check if the project is still shown
3. Got back to Projects, check if the project is still shown, and delete it again
4. Refresh page and check Overview/Projects

Actual results:
2. The project is still shown
3. The project is still shown. Delete it again, it will show: cannot delete projects in project "xxia-proj"
4. The project is not shown now

Expected results:
2. The project should disappear in Overview at once.
3. The project should disappear in Projects at once.

Additional info:
Comment 3 Peter 2017-07-26 13:35:07 EDT
Fix has been merged upstream.

https://github.com/cockpit-project/cockpit/pull/7368
Comment 5 yapei 2017-07-28 03:33:27 EDT
Checked against cockpit-147 with steps in "Steps to Reproduce", deleted projects will not be shown on Overview/Projects page.

Move to VERIFIED
Comment 7 errata-xmlrpc 2017-08-08 17:09:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2446

Note You need to log in before you can comment on or make changes to this bug.