Bug 146921 - FC3 locks on boot with smp kernel (hyperthreading)
FC3 locks on boot with smp kernel (hyperthreading)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 14:07 EST by James Blake
Modified: 2015-01-04 17:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Blake 2005-02-02 14:07:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Running on a P4 3GHz with hyperthreading, Fedora3 locks up whilst
starting up the services. I've tried disabling mouse console services
(ie gpm) and the xfs, since it used to lock up specifically at these
two until I worked out how to stop them. However, now it just locks at
no particular service eg sshd, readahead, atd, anacron etc.

However, it only locks when I boot with the smp version of the kernel,
running in "normal" mode, I have no probs at all.

I've tried upgrading the kernel, (this is the latest version of the
one on the machine), but the same smp problem persists.

The machine responds to ping requests when locked, and I can ssh to a
login, (at the terminal), but it doesn't respond to a password.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3smp

How reproducible:
Always

Steps to Reproduce:
1.Reboot
2.Choose the 'smp' option
3.Watch it lock up
    

Actual Results:  Machine locks up whilst starting the services

Expected Results:  Should've booted normally to and X-Windows login

Additional info:
Comment 1 Michael Mansour 2005-04-25 17:57:00 EDT
I have also experienced this exact same bug with RHEL4 kernel 2.6.9-
5.0.5, 

The way I got round it was to add:

acpi=off

to the grub kernel command as a parameter, and the system booted fine 
after that.
Comment 2 Michael Mansour 2005-04-26 20:15:55 EDT
I should also mention the main board which is having this issue:

http://www.asus.com/products/mb/socket478/p4s533-mx/overview.htm

It's an ASUS P4S533-MX with a SiS chipset.
Comment 3 Dave Jones 2005-07-15 14:36:20 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Dave Jones 2005-10-02 20:56:44 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.