Bug 146929 - prozilla 1.3.6 has exploitable security holes
prozilla 1.3.6 has exploitable security holes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: prozilla (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dams
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 15:23 EST by Richard Dawe
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.3.7.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 13:11:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Dawe 2005-02-02 15:23:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
prozilla 1.3.6 has a number of buffer overflows that are exploitable. See:

http://www.securityfocus.com/bid/11734/discussion/
http://bugs.gentoo.org/show_bug.cgi?id=70090

These bugs are fixed in prozilla 1.3.7.3. Please update the version in
Fedora Extras from http://prozilla.genesys.ro/ .

Version-Release number of selected component (if applicable):
1.3.6

How reproducible:
Sometimes

Steps to Reproduce:
I tried the exploit given in the Bugtraq article on my i386 box. It
didn't give me a shell, but it did crash prozilla with a segfault.

Additional info:
Comment 1 Michael Schwendt 2005-03-12 10:19:27 EST
Still no build request.
Comment 2 Richard Dawe 2005-03-12 10:40:29 EST
Sadly prozilla 1.3.7.3 also has some remotely exploitable security
holes. I've packaged up prozilla 1.3.7.4, which fixes these holes
thanks to some gentoo folks, but this is still in pre-release testing.

I'll let you know when prozilla 1.3.7.4 is released.
Comment 3 Richard Dawe 2005-03-24 14:35:33 EST
prozilla 1.3.7.4 is available <http://prozilla.genesys.ro/?p=download>. From NEWS:

"* Support for downloading files > 2GB.

* Fix a remotely exploitable format string security bug.

* Fix bugs in the handling of bad command-line options. Previously
  prozilla would return the success status code, even though it failed.
  Now it returns failure.

* Fix a segfault. This occurred when prozilla could not assemble a file
  due to lack of disk space and the user chose to abort the operation.

* Fix some typos."
Comment 4 Ville Skyttä 2005-10-03 13:11:30 EDT
1.3.7.4-1 is in the repos. 

Note You need to log in before you can comment on or make changes to this bug.