Bug 1469472 - [Openstack-containers][OSP12]: After HA with SSL deployment any usage of /home/stack/overcloudrc file will produce [SSL: CERTIFICATE_VERIFY_FAILED].
[Openstack-containers][OSP12]: After HA with SSL deployment any usage of /hom...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers (Show other bugs)
12.0 (Pike)
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Nathan Kinder
Omri Hochman
Andrew Burden
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 06:45 EDT by Omri Hochman
Modified: 2017-10-27 14:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-27 14:14:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2017-07-11 06:45:14 EDT
[Openstack-containers][OSP12]: After HA with SSL deployment any usage of /home/stack/overcloudrc file will produce [SSL: CERTIFICATE_VERIFY_FAILED]. 


Environment: 
------------
openstack-tripleo-heat-templates-7.0.0-0.20170628002128.el7ost.noarch
openstack-puppet-modules-10.0.0-0.20170315222135.0333c73.el7.1.noarch
openstack-heat-engine-9.0.0-0.20170628061551.30c87ba.el7ost.noarch
container images : -nova:2017-07-02.2


Description :
-------------
After HA with SSL deployment,   When attempting to source/use overcloudrc file and run command against the overcloud , the action will fail and  the outcome will be the following error 

ERROR (SSLError): SSL exception connecting to https://192.168.24.8:13000/v2.0/tokens: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:579)

Workaround :
------------- 
export OS_CACERT=/home/stack/cacert.pem

( or add this it ^ the overcloudrc . )
Comment 6 Omri Hochman 2017-10-27 14:14:08 EDT
Verified that overcloudrc works when cacert.pem file exists under the path : /etc/pki/ca-trust/source/anchors/cacert.pem 

I'm closing this issue as not a bug.

Note You need to log in before you can comment on or make changes to this bug.