Bug 1469496 - The engine does not show HE VM network interface
The engine does not show HE VM network interface
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
x86_64 Linux
high Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
Artyom
: Regression, Triaged
: 1469493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 08:00 EDT by Artyom
Modified: 2017-12-20 06:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:35:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
ui and engine logs (186.19 KB, application/zip)
2017-07-11 08:00 EDT, Artyom
no flags Details
screenshot (56.24 KB, image/png)
2017-07-11 08:01 EDT, Artyom
no flags Details

  None (edit)
Description Artyom 2017-07-11 08:00:22 EDT
Description of problem:
The engine does not show HE VM network interface

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170702100738.git46a9f67.el7.centos.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy HE
2. Add master storage domain
3. Wait for auto-import
4. Check HE VM NIC's

Actual results:
The engine does not show HE VM primary NIC and ui.log has error:
2017-07-11 14:52:13,653+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-32) [] Permutation name: D424918EE08B7776CAEC040E554E3FF9
2017-07-11 14:52:13,657+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-32) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) : Cannot read property 'a' of null
        at org.ovirt.engine.ui.common.widget.uicommon.vm.VmInterfaceListGroupItem.VmInterfaceListGroupItem(VmInterfaceListGroupItem.java:45)
        at org.ovirt.engine.ui.common.widget.uicommon.vm.VmInterfaceListModelTable.$createListViewItem(VmInterfaceListModelTable.java:88)
        at org.ovirt.engine.ui.common.widget.uicommon.vm.VmInterfaceListModelTable.createListViewItem(VmInterfaceListModelTable.java:88)
        at org.ovirt.engine.ui.common.widget.listgroup.PatternflyListView.$updateInfoPanel(PatternflyListView.java:117)
        at org.ovirt.engine.ui.common.widget.listgroup.PatternflyListView$lambda$1$Type.eventRaised(PatternflyListView.java:42)
        at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:99)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel.$setItems(SearchableListModel.java:702)
        at org.ovirt.engine.ui.uicommonweb.models.vms.VmInterfaceListModel.setItems(VmInterfaceListModel.java:251)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel$SetItemsAsyncQuery$1.$onSuccess(SearchableListModel.java:865)
        at org.ovirt.engine.ui.uicommonweb.models.SearchableListModel$SetItemsAsyncQuery$1.onSuccess(SearchableListModel.java:865)
        at org.ovirt.engine.ui.frontend.Frontend$1.$onSuccess(Frontend.java:227) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.Frontend$1.onSuccess(Frontend.java:227) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$1.$onSuccess(OperationProcessor.java:133) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$1.onSuccess(OperationProcessor.java:133) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$3$1.$onSuccess(GWTRPCCommunicationProvider.java:161) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$3$1.onSuccess(GWTRPCCommunicationProvider.java:161) [frontend.jar:]
        at com.google.gwt.user.client.rpc.impl.RequestCallbackAdapter.onResponseReceived(RequestCallbackAdapter.java:198) [gwt-servlet.jar:]
        at com.google.gwt.http.client.Request.$fireOnResponseReceived(Request.java:233) [gwt-servlet.jar:]
        at com.google.gwt.http.client.RequestBuilder$1.onReadyStateChange(RequestBuilder.java:409) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js)
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.eval(webadmin-0.js)


Expected results:
The engine shows HE VM primary NIC

Additional info:
Via REST I can see the NIC:
<nics>
<nichref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/nics/5286f03c-0dd2-4cb0-90a9-42a127c7a18c"id="5286f03c-0dd2-4cb0-90a9-42a127c7a18c">
<actions>
<linkhref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/nics/5286f03c-0dd2-4cb0-90a9-42a127c7a18c/deactivate"rel="deactivate"/>
<linkhref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/nics/5286f03c-0dd2-4cb0-90a9-42a127c7a18c/activate"rel="activate"/>
</actions>
<name>vnet0</name>
<linkhref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/nics/5286f03c-0dd2-4cb0-90a9-42a127c7a18c/networkfilterparameters"rel="networkfilterparameters"/>
<linkhref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/nics/5286f03c-0dd2-4cb0-90a9-42a127c7a18c/reporteddevices"rel="reporteddevices"/>
<linkhref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/nics/5286f03c-0dd2-4cb0-90a9-42a127c7a18c/statistics"rel="statistics"/>
<vmhref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7"id="d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7"/>
<interface>virtio</interface>
<linked>true</linked>
<mac>
<address>00:1a:4a:16:10:9f</address>
</mac>
<plugged>true</plugged>
<reported_devices>
<reported_devicehref="/ovirt-engine/api/vms/d56ee9b2-d9b1-4d70-96ea-bf04cdcdf3b7/reporteddevices/65746830-3030-3a31-613a-34613a31363a"id="65746830-3030-3a31-613a-34613a31363a">…</reported_device>
</reported_devices>
<vnic_profilehref="/ovirt-engine/api/vnicprofiles/0000000a-000a-000a-000a-000000000398"id="0000000a-000a-000a-000a-000000000398"/>
</nic>
</nics>
Comment 1 Artyom 2017-07-11 08:00 EDT
Created attachment 1296195 [details]
ui and engine logs
Comment 2 Artyom 2017-07-11 08:01 EDT
Created attachment 1296196 [details]
screenshot
Comment 3 Artyom 2017-07-11 08:33:30 EDT
*** Bug 1469493 has been marked as a duplicate of this bug. ***
Comment 4 Martin Perina 2017-07-11 08:51:34 EDT
Alexander, could you please take a look as you have added VmInterfaceListGroupItem in https://gerrit.ovirt.org/75669 ?
Comment 5 Oved Ourfali 2017-07-18 04:19:59 EDT
We'll explore it, and move to Network if needed.
Comment 6 Red Hat Bugzilla Rules Engine 2017-07-18 13:37:02 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 7 Alexander Wels 2017-07-24 16:52:23 EDT
So I am working on a patch that may or may not fix this as it is a fairly substantial rework of both the host interfaces and the VM interfaces (I want the look to be cohesive). Once that is posted can we retest?
Comment 8 Oved Ourfali 2017-08-20 07:38:17 EDT
Please re-test on latest nightly.
Comment 9 Artyom 2017-09-03 06:59:31 EDT
Verified on ovirt-engine-4.2.0-0.0.master.20170901193740.git7900511.el7.centos.noarch
Comment 10 Sandro Bonazzola 2017-12-20 06:35:52 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.