Bug 1469524 - blivet.errors.LUKSError: luks device not configured
blivet.errors.LUKSError: luks device not configured
Status: CLOSED DUPLICATE of bug 1466940
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:526bd9cd05509ee81c548ec3700...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 08:34 EDT by Alessio
Modified: 2017-07-12 01:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 01:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.89 MB, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: anaconda.log (79.11 KB, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: environ (596 bytes, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: journalctl (661.51 KB, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: lsblk_output (2.04 KB, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: lvm.log (231.49 KB, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: nmcli_dev_list (2.43 KB, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: os_info (518 bytes, text/plain)
2017-07-11 08:34 EDT, Alessio
no flags Details
File: program.log (154.20 KB, text/plain)
2017-07-11 08:35 EDT, Alessio
no flags Details
File: storage.log (705.79 KB, text/plain)
2017-07-11 08:35 EDT, Alessio
no flags Details
File: ifcfg.log (6.41 KB, text/plain)
2017-07-11 08:35 EDT, Alessio
no flags Details

  None (edit)
Description Alessio 2017-07-11 08:34:33 EDT
Description of problem:
Repartitioning a disk containing an encrypted partition.

Version-Release number of selected component:
anaconda-core-26.21.11-1.fc26.x86_64

The following was filed automatically by anaconda:
anaconda 26.21.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/formats/luks.py", line 217, in _pre_setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 599, in setup
    if not self._pre_setup(**kwargs):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 506, in setup_parents
    _format.setup()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 363, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 374, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 498, in setup_parents
    parent.setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 363, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 230, in _pre_setup
    return StorageDevice._pre_setup(self, orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 374, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/device.py", line 209, in setup_parents
    parent.setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1932, in setup_parents
    Device.setup_parents(self, orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 363, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 895, in _pre_setup
    if not super(LVMLogicalVolumeBase, self)._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 374, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1936, in setup
    return DMDevice.setup(self, orig)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1839, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 695, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 325, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 163, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1112, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 437, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 471, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install_tasks.py", line 303, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/install.py", line 363, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self)
blivet.errors.LUKSError: luks device not configured

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-WS-Live-26-1-5 rd.live.image rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
other involved packages: system-python-libs-3.6.1-8.fc26.x86_64, python3-blivet-2.1.9-1.fc26.noarch
product:        Fedora
release:        Fedora release 26 (Twenty Six)
type:           anaconda
version:        26
Comment 1 Alessio 2017-07-11 08:34:43 EDT
Created attachment 1296213 [details]
File: anaconda-tb
Comment 2 Alessio 2017-07-11 08:34:46 EDT
Created attachment 1296214 [details]
File: anaconda.log
Comment 3 Alessio 2017-07-11 08:34:47 EDT
Created attachment 1296215 [details]
File: environ
Comment 4 Alessio 2017-07-11 08:34:51 EDT
Created attachment 1296216 [details]
File: journalctl
Comment 5 Alessio 2017-07-11 08:34:53 EDT
Created attachment 1296218 [details]
File: lsblk_output
Comment 6 Alessio 2017-07-11 08:34:56 EDT
Created attachment 1296219 [details]
File: lvm.log
Comment 7 Alessio 2017-07-11 08:34:57 EDT
Created attachment 1296220 [details]
File: nmcli_dev_list
Comment 8 Alessio 2017-07-11 08:34:59 EDT
Created attachment 1296221 [details]
File: os_info
Comment 9 Alessio 2017-07-11 08:35:01 EDT
Created attachment 1296222 [details]
File: program.log
Comment 10 Alessio 2017-07-11 08:35:05 EDT
Created attachment 1296223 [details]
File: storage.log
Comment 11 Alessio 2017-07-11 08:35:07 EDT
Created attachment 1296224 [details]
File: ifcfg.log
Comment 12 Alessio 2017-07-11 08:50:14 EDT
BTW, doing the task again it worked.
Comment 13 Vojtech Trefny 2017-07-12 01:11:38 EDT
Thank you for the report, the error is different, but based on the logs this is probably duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1466940

*** This bug has been marked as a duplicate of bug 1466940 ***

Note You need to log in before you can comment on or make changes to this bug.