Bug 1469543 - Deploying Kibana Ops Cluster with Dynamic PV does not create PV/PVC for the Ops cluster Pods
Deploying Kibana Ops Cluster with Dynamic PV does not create PV/PVC for the O...
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.4.0
All All
unspecified Severity low
: ---
: ---
Assigned To: Jeff Cantrill
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 09:19 EDT by Bruno Andrade
Modified: 2018-02-13 14:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-13 14:10:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Host inventory (6.38 KB, text/plain)
2017-07-11 09:19 EDT, Bruno Andrade
no flags Details

  None (edit)
Description Bruno Andrade 2017-07-11 09:19:32 EDT
Created attachment 1296253 [details]
Host inventory

Description of problem:

We attempted to run the installer in AWS with the ops cluster value =true and tried to provide the correct values for the OPS components.   The Resulting installation did create the Ops Pods, but only with emptyDir and did not populate the ConfigMap with the Ops values as expected.

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
Use the ansible host variables attached to file client-hostfile to do a fresh advanced install

##################################################################
# Logging Deployment Configuration
##################################################################
openshift_hosted_logging_deploy=true
openshift_hosted_logging_storage_kind=dynamic
openshift_hosted_logging_storage_volume_size=100Gi
openshift_hosted_logging_elasticsearch_instance_ram=4G
openshift_hosted_logging_elasticsearch_nodeselector='region=infra'
openshift_hosted_logging_kibana_nodeselector='region=infra'
openshift_hosted_logging_curator_nodeselector='region=infra'
 
openshift_hosted_logging_enable_ops_cluster=true
openshift_hosted_logging_elasticsearch_ops_pvc_size=100Gi
openshift_hosted_logging_elasticsearch_ops_pvc_dynamic=true
openshift_hosted_logging_elasticsearch_ops_instance_ram=4G
openshift_hosted_logging_elasticsearch_ops_nodeselector='region=infra'
openshift_hosted_logging_kibana_ops_nodeselector='region=infra'
openshift_hosted_logging_curator_ops_nodeselector='region=infra'

Actual results:
Requires manually edit/redeployment of the Logging templates to correct, so impacts the efficiency and complexity of a installation by requiring additional steps.

Expected results:
Do not need manually edit/redeployment since all informations are on ansible inventory file.

Additional info:
Comment 2 Jeff Cantrill 2018-02-13 14:10:56 EST
Closing as deployment has changed and we are unlikely to fix in 3.4

Note You need to log in before you can comment on or make changes to this bug.