Bug 1469668 - Provider Configuration returns truncated list of tenants
Provider Configuration returns truncated list of tenants
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: cfme-future
Assigned To: Sam Lucidi
Ola Pavlenko
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 11:16 EDT by Chris Paquin
Modified: 2017-08-07 08:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 11:12:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack


Attachments (Terms of Use)

  None (edit)
Description Chris Paquin 2017-07-11 11:16:12 EDT
Description of problem:

Our OSP 8 env users AD. We have created an AD user and have added that user as admin to all 130 tenants. We have run into two issues.

1. We cannot add the provider to CF as the validation of the user credentials times out before it can validate the user for each tenant. The only way to add the provider is to remove the admin role from all projects except for 1 tenant, then add provider and once validated and saved, add the admin role back for each tenant. 

2. Once added as a provider, CF seems to truncate the list of tenants to 30 (out of 173). Alphabetically, the list of tenants stops somewhere in "H".



Version-Release number of selected component (if applicable):
5.8

How reproducible:
Create AD service account user in OpenStack, add admin role for this user to all tenants. Add provider using new AD service account

Actual results:
Unable to add AD service account as a provider with when admin of all 173 tenants, can remove admin role for all but one tenant and add/validate as a provider. Add admin role back to all 173 tenants, CF only shows first 30 tenants, stops at the letter "H"


Expected results:
CF should return all 173 tenants and corresponding OSP instances, images, etc. 


Additional info:
Comment 2 Sam Lucidi 2017-07-11 16:26:32 EDT
I'm not currently able to reproduce the tenant truncation problem. In order to differentiate between a UI problem or a possible inventory problem, can you confirm whether all of the tenants are present in the manageiq database?
Comment 4 Chris Paquin 2017-07-11 17:21:43 EDT
Only 87 tenants are in the database - see new attachment.
Comment 5 Tzu-Mainn Chen 2017-07-11 17:29:53 EDT
If that's the case, I wonder if this issue was caused by an incomplete refresh due to adjustments to tenants. Is it possible to see if Sam's fix for https://bugzilla.redhat.com/show_bug.cgi?id=1469306 also solves this issue?
Comment 7 Tzu-Mainn Chen 2017-07-12 17:21:11 EDT
I believe we determined that this was due to projects/tenants being in different domains. Can this BZ be closed... ?
Comment 8 Chris Paquin 2017-07-13 11:12:05 EDT
Closing BZ, this is not a bug. Related to empty projects being created via heat during heat-stack creation. This might be a CF bug or just default ( and undesirable) behavior in OSP, but definitely not an issue for Cloudforms.

Note You need to log in before you can comment on or make changes to this bug.