Bug 1469765 - Dangling symlink in rh-eclipse47-eclipse-ptp-sdm-9.1.2-3.1.el7.x86_64
Dangling symlink in rh-eclipse47-eclipse-ptp-sdm-9.1.2-3.1.el7.x86_64
Status: CLOSED ERRATA
Product: DevTools
Classification: Red Hat
Component: rh-eclipse47 (Show other bugs)
rh-eclipse47
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.0
Assigned To: Mat Booth
Václav Kadlčík
Robert Krátký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 15:37 EDT by Nick Boldt
Modified: 2017-08-15 11:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: rh-eclipse47-eclipse-ptp-9.1.2-4.1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 11:05:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2476 normal SHIPPED_LIVE rh-eclipse47 bug fix and enhancement update 2017-08-15 15:01:40 EDT

  None (edit)
Description Nick Boldt 2017-07-11 15:37:10 EDT
Description of problem:

[ERROR] Can't find '/opt/rh/rh-eclipse47/root/usr/lib64/ptp/sdm' -> '/opt/rh/rh-eclipse47/root/usr/lib*/eclipse/droplets/ptp-sdm/eclipse/plugins/org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm'

Version-Release number of selected component (if applicable):

rh-eclipse47-eclipse-ptp-sdm-9.1.2-3.1.el7.x86_64

How reproducible: always


Steps to Reproduce:
1. Run this script [1]
2. ./errataWaiveChecker.sh -e https://errata.devel.redhat.com/rpmdiff/show/177006?result_id=4852895 -p "dangling symlink" -I 
3. Review log

[1] https://github.com/jbosstools/jbosstools-build-ci/blob/master/util/errataWaiveChecker.sh

Actual results:

[ERROR] Can't find '/opt/rh/rh-eclipse47/root/usr/lib64/ptp/sdm' -> '/opt/rh/rh-eclipse47/root/usr/lib*/eclipse/droplets/ptp-sdm/eclipse/plugins/org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm'

[ERROR] For rh-eclipse47-eclipse-ptp-sdm, found 1 of 5 dangling symlinks at https://errata.devel.redhat.com/rpmdiff/show/177021?result_id=4853557


Expected results:

[INFO] For rh-eclipse47-eclipse-ptp-sdm, found 0 of 5 dangling symlinks at https://errata.devel.redhat.com/rpmdiff/show/177021?result_id=4853557

Additional info:
Comment 1 Nick Boldt 2017-07-11 15:38:54 EDT
The actual file is here:

$➔ file /opt/rh/rh-eclipse47/root/usr/lib/eclipse/droplets/ptp-sdm/eclipse/plugins/org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm
/opt/rh/rh-eclipse47/root/usr/lib/eclipse/droplets/ptp-sdm/eclipse/plugins/org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=cd29df75581523748ae1e2f1a5406f3d3b091078, stripped

But symlinking to a path with an asterisk doesn't seem to resolve for me (on F24 anyway). So I would suggest the symlink remove the asterisk, in order to not get this error:

$➔ file /opt/rh/rh-eclipse47/root/usr/lib64/ptp/sdm
/opt/rh/rh-eclipse47/root/usr/lib64/ptp/sdm: broken symbolic link to /opt/rh/rh-eclipse47/root/usr/lib*/eclipse/droplets/ptp-sdm/eclipse/plugins/org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm
Comment 2 Mat Booth 2017-07-19 10:29:22 EDT
(In reply to Nick Boldt from comment #1)
> The actual file is here:
> 
> $➔ file
> /opt/rh/rh-eclipse47/root/usr/lib/eclipse/droplets/ptp-sdm/eclipse/plugins/
> org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm
> /opt/rh/rh-eclipse47/root/usr/lib/eclipse/droplets/ptp-sdm/eclipse/plugins/
> org.eclipse.ptp.linux_9.1.2.201704021416/os/linux/x86_64/sdm: ELF 64-bit LSB
> executable, x86-64, version 1 (SYSV), dynamically linked, interpreter
> /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32,
> BuildID[sha1]=cd29df75581523748ae1e2f1a5406f3d3b091078, stripped
> 
> But symlinking to a path with an asterisk doesn't seem to resolve for me (on
> F24 anyway). So I would suggest the symlink remove the asterisk, in order to
> not get this error:


This was probably always broken on 32-bit arches, but no-one noticed until Eclipse moved to /usr/lib on all arches. I fixed in Fedora and back-ported to rh-eclipse47
Comment 5 errata-xmlrpc 2017-08-15 11:05:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2476

Note You need to log in before you can comment on or make changes to this bug.